User Tag List

Page 1 of 2 1 2 LastLast
Results 1 to 10 of 19

Thread: Extension is not installed

  1. #1
    Clicker Fusion 2.5 MacFusion 2.5 DeveloperAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleSWF Export ModuleXNA Export ModuleUnicode Add-on
    Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Fusion 2.5+ DLC (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)
    Phi's Avatar
    Join Date
    Jan 2010
    Location
    England
    Posts
    1,796
    Mentioned
    10 Post(s)
    Tagged
    0 Thread(s)

    Exclamation Extension is not installed

    I'm trying to open a file using an extension which can be dropped and used freely in new applications. But opening a particular MFA gives me this:


    It's not in blocked extensions, and it loads fine in a blank program. I also removed a mfx file with a similar name just in case the two were conflicting. Even DllMain() isn't executed during the load; there's a first-chance CFileException (once), then subsequent attempts to load don't even throw that one.

    I'm at a loss. Surely there'd be a different error message if it existed but couldn't be accessed. I attached the extension if you guys want to test.
    DebugObject.zip

  2. #2
    Clickteam Clickteam
    LB's Avatar
    Join Date
    Jun 2007
    Location
    Richardson, Texas, North America
    Posts
    8,937
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Opening a particular MFA? Are you sure it's not corrupt?

  3. #3
    Clicker Fusion 2.5 MacFusion 2.5 DeveloperAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleSWF Export ModuleXNA Export ModuleUnicode Add-on
    Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Fusion 2.5+ DLC (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)
    Phi's Avatar
    Join Date
    Jan 2010
    Location
    England
    Posts
    1,796
    Mentioned
    10 Post(s)
    Tagged
    0 Thread(s)
    Yes, it's not corrupt, none of the 100 auto-backups work either. Just one day, poof, this error.

  4. #4
    Clickteam Clickteam
    LB's Avatar
    Join Date
    Jun 2007
    Location
    Richardson, Texas, North America
    Posts
    8,937
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    What I mean is, do new MFAs you save have this problem?

  5. #5
    Clicker Fusion 2.5 MacFusion 2.5 DeveloperAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleSWF Export ModuleXNA Export ModuleUnicode Add-on
    Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Fusion 2.5+ DLC (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)
    Phi's Avatar
    Join Date
    Jan 2010
    Location
    England
    Posts
    1,796
    Mentioned
    10 Post(s)
    Tagged
    0 Thread(s)
    Good catch, but no, they save and load fine.

  6. #6
    Clickteam Clickteam
    LB's Avatar
    Join Date
    Jun 2007
    Location
    Richardson, Texas, North America
    Posts
    8,937
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    If new MFAs do not have the problem, but all your backups of that one MFA do have that problem, then you have probably just made a change that causes your extension to be compatible with all previous versions. Do you know what you might have changed to cause that, or at least when?

    Also, make sure to clear out any extra duplicates of old versions of the MFX - often times old Unicode or HWA versions remain and MMF2 for some reason has inconsistent priorities for which MFX it loads. This happened to me and was very frustrating.

  7. #7
    Clicker Fusion 2.5 MacFusion 2.5 DeveloperAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleSWF Export ModuleXNA Export ModuleUnicode Add-on
    Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Fusion 2.5+ DLC (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)
    Phi's Avatar
    Join Date
    Jan 2010
    Location
    England
    Posts
    1,796
    Mentioned
    10 Post(s)
    Tagged
    0 Thread(s)
    Nope LB, I have no idea what would cause the problem. I haven't removed any a/c/e, and it should be a complete match to an old version otherwise - at the very least, one of the 100 autobackups would be using a compatible version.

  8. #8
    Clickteam Clickteam
    LB's Avatar
    Join Date
    Jun 2007
    Location
    Richardson, Texas, North America
    Posts
    8,937
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by Phi View Post
    it should be a complete match to an old version otherwise
    So you rewrote it with another SDK?

  9. #9
    Clicker Fusion 2.5 MacFusion 2.5 DeveloperAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleSWF Export ModuleXNA Export ModuleUnicode Add-on
    Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Fusion 2.5+ DLC (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)
    Phi's Avatar
    Join Date
    Jan 2010
    Location
    England
    Posts
    1,796
    Mentioned
    10 Post(s)
    Tagged
    0 Thread(s)
    No, same SDK consistently.

  10. #10
    Clickteam Clickteam
    LB's Avatar
    Join Date
    Jun 2007
    Location
    Richardson, Texas, North America
    Posts
    8,937
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Did the version of your compiler change at all?

Page 1 of 2 1 2 LastLast

Similar Threads

  1. "Do Not Install If Later Version is Installed" feature. No warning, files installed.
    By TheDonald in forum Install Creator and Patch Maker
    Replies: 8
    Last Post: 1st August 2013, 06:40 PM
  2. MMF2 not installed?
    By fish20 in forum Multimedia Fusion 2 - Technical Support
    Replies: 2
    Last Post: 27th May 2010, 08:12 PM
  3. Set an installed exe to autostart...
    By ISO in forum Install Creator and Patch Maker
    Replies: 1
    Last Post: 17th September 2008, 12:13 PM
  4. Installed Extensions...
    By IsaacBoy in forum Multimedia Fusion 2 - Technical Support
    Replies: 9
    Last Post: 5th May 2008, 02:29 PM
  5. Test if font is installed
    By MechatheSlag in forum Multimedia Fusion 2 - Technical Support
    Replies: 2
    Last Post: 8th August 2007, 07:02 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •