User Tag List

Results 1 to 1 of 1

Thread: Object Not Triggering Animation 100% of the Time

  1. #1
    No Products Registered

    Join Date
    Sep 2013
    Posts
    1
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Object Not Triggering Animation 100% of the Time

    Hey all!

    I'm new to MMF2, but I've put a lot of time into scouring the various sites and tutorials to learn my way through any issues that have come up. Well...up to this point at least. I'm having an issue where an event is being triggered, and it will always destroy a designated rocket object, but it will only SOMETIMES trigger a triangle object to change its animation.

    If you could give it a whirl on the attached game file, it's quite an easy issue to see. When starting the game and selecting the triangle that is in front of the first launcher block, once you press the fire button a rocket shoots out and hits this target. However, while the triangle should change its animation when hit by this rocket, sometimes only the rocket is destroyed while the triangle never changes its animations.


    I have tested this issue out to great lengths to see what the inherent problem is, and I've come down to a couple of assumptions.

    1. The rocket object that is part of the condition of an event is moving at such a fast speed, that the loop that is checking for it at a certain "Y-Position" sometimes misses going through all parts of the actions when the event is finally triggered.

    2. The "Change Animation" of the triangle object that is supposed to trigger on the same event as the "Destroy" rocket object, is too slow.

    Any suggestions or help at all would REALLY be appreciated. I'm willing to try anything and gut the system in order to make sure this runs reliably 100% of the time.

    Cheers and love!
    Attached files Attached files

Similar Threads

  1. [BUG?]limited time loop animation not stop
    By ASD in forum Multimedia Fusion 2 - Technical Support
    Replies: 0
    Last Post: 24th July 2013, 03:16 PM
  2. Help - Time or animation frame?!
    By Petedevlin in forum Multimedia Fusion 2 - Technical Support
    Replies: 2
    Last Post: 4th May 2013, 05:41 AM
  3. Code not triggering, need help
    By Sumo in forum Multimedia Fusion 2 - Technical Support
    Replies: 6
    Last Post: 27th January 2013, 05:32 PM
  4. Beta 5: Jittery Animation (in time)
    By UrbanMonk in forum iOS Export Module Version 2.0
    Replies: 4
    Last Post: 22nd November 2010, 09:37 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •