User Tag List

Results 1 to 4 of 4

Thread: Anyone able to figure out what is wrong with this frame?

  1. #1
    Clicker Fusion 2.5

    Join Date
    Jun 2006
    Posts
    399
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)

    Question FPS drop with a big frame with three objects.

    It seems that just the one backdrop will cause the application to drop FPS very quickly on a big frame. Should this happen? Look at the attachement:

    Using: Fusion 2.5 with latest build on Windows 7 64bit. Will provide more information if anyone needs it.

    EDIT: I sent a bug report and Yves kindly answered and it solves all the issues. I feel pretty stupid now, but here is his response:

    This lag seems to be due to the "Handle background collisions even out of window option". In this mode the program creates a global collision mask for the first level. Perhaps the size of the collision mask in your frame is too big (even if it uses only 2 bits per pixel, for a 30,000 x 30,000 frame it will eat 225 Mb of memory).

    2 solutions:

    - either you unselect this option
    - or you create an empty first layer and move the current layer above it. Layers greater than 1 have no global collision mask. Other differences with the first layer: the Paste Backdrop option works like Add Backdrop for these layers, and you can "paste" a non-obstacle backdrop to make a hole in the collision mask.
    Attached files Attached files

  2. #2
    Clickteam Clickteam
    Jeff's Avatar
    Join Date
    Jun 2006
    Location
    Battle Ground Washington
    Posts
    11,821
    Mentioned
    7 Post(s)
    Tagged
    2 Thread(s)
    Strange - if you can put in a bug report about it that would be a good idea.
    Something isn't right there

  3. #3
    Clicker Fusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export ModuleiOS Export ModuleSWF Export Module
    Skyhunter's Avatar
    Join Date
    Jan 2007
    Location
    Croatia
    Posts
    451
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    It is actually the same as in mmf2.

    The slowdown happens on a large frame size with direct3d9 and an obstacle backdrop.

  4. #4
    Clicker Fusion 2.5

    Join Date
    Jun 2006
    Posts
    399
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by Jeff View Post
    Strange - if you can put in a bug report about it that would be a good idea.
    Something isn't right there
    I've made a "new issue" on BugBox.

    I hope this gets resolved really soon as this is a massive problem for my project. Not sure why it lags exactly, but I remember making large frame games and not having issues.

    UPDATE: Read OP for update.

Similar Threads

  1. Halp, can't figure out what I'm doing wrong with the Timer.
    By ecoste in forum Multimedia Fusion 2 - Technical Support
    Replies: 3
    Last Post: 19th December 2013, 05:47 PM
  2. Jumps in the wrong direction. Cant figure this one out :/
    By Outcast in forum Multimedia Fusion 2 - Technical Support
    Replies: 2
    Last Post: 29th July 2012, 08:06 PM
  3. [Bug] Buttons gets wrong position when switching frame
    By Popcorn in forum Android Export Module Version 2.0
    Replies: 0
    Last Post: 17th November 2011, 05:53 PM
  4. What is wrong with the green frame?
    By vesperillo in forum File Archive
    Replies: 13
    Last Post: 8th April 2010, 06:18 AM
  5. What's wrong with my frame rate?
    By Karl in forum Multimedia Fusion 2 - Technical Support
    Replies: 4
    Last Post: 30th January 2009, 02:12 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •