User Tag List

Results 1 to 4 of 4

Thread: Problem with Windows Phone Ads

  1. #1
    Clicker Fusion 2.5 DeveloperAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleXNA Export Module

    Join Date
    Jun 2012
    Posts
    129
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Problem with Windows Phone Ads

    I'm not sure why this problem is popping up now since I've used ads with the Microsoft Pubcenter before, but now anytime I try to compile a Windows Phone project using ads, I get these errors:

    Error 1 The type or namespace name 'Advertising' does not exist in the namespace 'Microsoft' (are you missing an assembly reference?)
    Error 2 The type or namespace name 'Advertising' does not exist in the namespace 'Microsoft' (are you missing an assembly reference?)
    Error 3 The type or namespace name 'AdGameComponent' could not be found (are you missing a using directive or an assembly reference?)
    Error 4 The type or namespace name 'DrawableAd' could not be found (are you missing a using directive or an assembly reference?)


    Any ideas on what could be wrong?

  2. #2
    Clicker Fusion 2.5 DeveloperAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleXNA Export Module

    Join Date
    Jun 2012
    Posts
    129
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I found this problem in a different post and used the solution posted there! I just had to download the newest Windows Phone SDK and Advertising SDK and it works now.

  3. #3
    Clicker Fusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleUniversal Windows Platform Export ModuleXNA Export Module
    Dobermann's Avatar
    Join Date
    Feb 2009
    Location
    France
    Posts
    679
    Mentioned
    26 Post(s)
    Tagged
    0 Thread(s)
    I have no problem to compile my project that use the XNA Ads object with VS2010, but when i try it under VS2010's emulator, it don't display the Ads. I've tried to use "test_client" as App ID and "300x50" as AD Unit but still showing nothing...

    Any idea on how to make it works?

    Got the Test Ads displaying by replacing "300x50" by "300_50" that is the real code to put. But i can't see any ad displayng while using the pubcenter ID and Unit...

  4. #4
    Clicker Fusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleUniversal Windows Platform Export ModuleXNA Export Module
    Dobermann's Avatar
    Join Date
    Feb 2009
    Location
    France
    Posts
    679
    Mentioned
    26 Post(s)
    Tagged
    0 Thread(s)
    I finally decided to gave up with ads...

Similar Threads

  1. XNA, Windows Phone
    By Francois in forum XNA Export Module Version 2.0
    Replies: 6
    Last Post: 14th June 2013, 05:44 AM
  2. Windows Phone 8 and IAPs
    By DTownTony in forum XNA Export Module Version 2.0
    Replies: 3
    Last Post: 7th September 2012, 07:06 AM
  3. Requirement for Windows Phone 7
    By jbrown2177 in forum XNA Export Module Version 2.0
    Replies: 1
    Last Post: 28th July 2012, 08:55 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •