User Tag List

Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14

Thread: WebView for Android - "Get HTML source" return nothing

  1. #1
    Clicker Fusion 2.5 DeveloperHTML5 Export Module

    Join Date
    Jan 2014
    Location
    Paris, France
    Posts
    60
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    WebView for Android - "Get HTML source" return nothing

    Bug occured on Samsung galaxy ace when trying to get the source of a .aspx.

    FVivolo, what is your opinion ? :/

    And if someone may test this action under other device to confirm ?

  2. #2
    Clickteam Clickteam
    Fernando's Avatar
    Join Date
    Dec 2006
    Posts
    6,143
    Mentioned
    158 Post(s)
    Tagged
    3 Thread(s)
    Regards,


    Fernando Vivolo

    ... new things are coming ...

  3. #3
    Clicker Fusion 2.5 DeveloperHTML5 Export Module

    Join Date
    Jan 2014
    Location
    Paris, France
    Posts
    60
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Twice work fine, I get the source. I re-tested my own link, it don't work...

    The url i am browsing contain a http basic authentification (login:password@website.com) it work fine on Windows, the session is "saved", but not in Android, the server send a 401.2 error "not autorized because sending a www-authentificate header field that the server is not configured to accept"

  4. #4
    Clickteam Clickteam
    Fernando's Avatar
    Join Date
    Dec 2006
    Posts
    6,143
    Mentioned
    158 Post(s)
    Tagged
    3 Thread(s)
    ok, that page is requesting a certificate to be send when browsing, that is a problem since that certificate need to be added to the devices so you can access correct that page.

    try chrome fro android to see if you can get the access to it.
    Regards,


    Fernando Vivolo

    ... new things are coming ...

  5. #5
    Clicker Fusion 2.5 DeveloperHTML5 Export Module

    Join Date
    Jan 2014
    Location
    Paris, France
    Posts
    60
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks four your reply
    Ok but how to add certificate to the request ?

  6. #6
    Clickteam Clickteam
    Fernando's Avatar
    Join Date
    Dec 2006
    Posts
    6,143
    Mentioned
    158 Post(s)
    Tagged
    3 Thread(s)
    not implemented since it should be package inside the application.

    another way is that a browser need it and downloaded in the cache and when need it by webview it will look for it
    Regards,


    Fernando Vivolo

    ... new things are coming ...

  7. #7
    Clicker Fusion 2.5 DeveloperHTML5 Export Module

    Join Date
    Jan 2014
    Location
    Paris, France
    Posts
    60
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    So if the built-in browser load certificate and then if I launch webview, it will retrieve this certificate and send it? I tested this method but it didn't worked.

    I have another question. Webview for Windows use Internet Explorer packages. So for Android, it should use the built-in Internet browser packages; with this built-in browser, the connection login:password@host work fine, connection is effective and keeped alive.

    Why isn't it the same for Webview?

    Edward

  8. #8
    Clickteam Clickteam
    Fernando's Avatar
    Join Date
    Dec 2006
    Posts
    6,143
    Mentioned
    158 Post(s)
    Tagged
    3 Thread(s)
    yes, should do,

    see also in "setting" there is for android 4 to above (i think) something like ---"security"---"credential storage"--- (credential protection in the menu).
    Regards,


    Fernando Vivolo

    ... new things are coming ...

  9. #9
    Clicker Fusion 2.5 DeveloperHTML5 Export Module

    Join Date
    Jan 2014
    Location
    Paris, France
    Posts
    60
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I'm under 2.3, I can only define a password for this data..
    Have you any idea of why webview don't get itself the requested certificate ?

  10. #10
    Clicker Fusion 2.5 DeveloperAndroid Export ModuleHTML5 Export ModuleSWF Export Module
    DavidT's Avatar
    Join Date
    Sep 2011
    Posts
    160
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    "Get HTML Source" of the Web View Object returns nothing on my device when I put "target Android version" on 4.2 and above, while below 4.2 it works well. I have updated Fusion, Android Exporter and Web View Object but it's still the same. You can see the attached file. I'm just trying to display the HTML code of this page : http://www.w3schools.com/aspnet/firstpage.aspx

    How can I make it work?
    Attached files Attached files

Page 1 of 2 1 2 LastLast

Similar Threads

  1. How to load a .html file with "Web View Object"
    By fishrod in forum Multimedia Fusion 2 - Technical Support
    Replies: 4
    Last Post: 19th January 2014, 05:37 PM
  2. UPnUP - Android game "made with fusion" on Google Play
    By qenio in forum Android Export Module Version 2.0
    Replies: 7
    Last Post: 4th April 2013, 10:23 AM
  3. [BUG RC1] ScreenHeight("Android object") is not actual screen height
    By Bipolar_Games in forum Android Export Module Version 2.0
    Replies: 0
    Last Post: 11th October 2012, 06:56 PM
  4. Adding Return to "Change alterable Text" event
    By Teh_Purple_d00d in forum Multimedia Fusion 2 - Technical Support
    Replies: 2
    Last Post: 19th December 2011, 01:45 AM
  5. Mochi Social return "null" string...
    By Orelbe in forum SWF/Flash Export Module Version 2.0
    Replies: 4
    Last Post: 24th July 2011, 04:51 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •