User Tag List

Results 1 to 7 of 7

Thread: White screen after preloader

  1. #1
    Clickteam Clickteam
    Olivier's Avatar
    Join Date
    Jun 2006
    Posts
    2,996
    Mentioned
    9 Post(s)
    Tagged
    1 Thread(s)

    White screen after preloader

    I can see a plain white screen right after the preloader and before the actual game begins. The bigger the game, the longer the duration of that white screen. With a very light-weight game it is barely noticeable. But with my 4 megs .swf the white screen lasts for 5-6 seconds and it is very annoying. Can something de done about it?

    This happens with any type of preloader, image or application. And I believe that it also happens with HTML5 apps.
    I have tried to change the way sounds are loaded (preload, load on call, play from disk) but the result is still the same.

  2. #2
    Clicker Fusion 2.5 DeveloperAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleSWF Export ModuleMac Export ModuleUnicode Add-on
    Pharanygitis's Avatar
    Join Date
    Aug 2006
    Location
    Germany
    Posts
    1,037
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    hm, is this problem only when you activate the preloader as image or application?
    Remove any preloader from your application and test it again... now, you see the "standart"-preloader from adobe. Have you here exactly the same problem, is the problem on the flash application and not on the preloader.

  3. #3
    Clickteam Clickteam
    Olivier's Avatar
    Join Date
    Jun 2006
    Posts
    2,996
    Mentioned
    9 Post(s)
    Tagged
    1 Thread(s)
    The problem happens in all the 3 cases: no preloader defined (i.e. standard adobe preloader), image preloader, application preloader. So yes, the problem is definitely tied to the game itself not the preloader. If you have a developer account at FGL you can check the game by yourself here:
    https://www.fgl.com/view_game.php?fr...&game_id=33069

    I wonder if this is due to the way our Fusion-made games work. Right after the preloader, the interpreter (?) might take some time to load the whole game at once?

  4. #4
    Clicker Fusion 2.5 DeveloperAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleSWF Export ModuleMac Export ModuleUnicode Add-on
    Pharanygitis's Avatar
    Join Date
    Aug 2006
    Location
    Germany
    Posts
    1,037
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I can't see the game on FGL :-/

    Access Denied

    Have you a other link to your game ?

  5. #5
    Clickteam Clickteam
    Olivier's Avatar
    Join Date
    Jun 2006
    Posts
    2,996
    Mentioned
    9 Post(s)
    Tagged
    1 Thread(s)
    I've just sent you an email Jens. The game is somewhat kept private at FGL.com and it's better like this since I will soon seek sponsorship for it.

  6. #6
    Clicker Fusion 2.5 DeveloperAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleSWF Export ModuleMac Export ModuleUnicode Add-on
    Pharanygitis's Avatar
    Join Date
    Aug 2006
    Location
    Germany
    Posts
    1,037
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Ok, thank you, I have tested it. First, nice game !
    Secound, the game loads very fast for me, no waiting time! I have tested on chrome and firefox with the flashplayer 12... no errors, no waiting time.
    What is your Flashplayer version? And have you tested on chrome or firefox? or on IE ?

  7. #7
    Clickteam Clickteam
    Olivier's Avatar
    Join Date
    Jun 2006
    Posts
    2,996
    Mentioned
    9 Post(s)
    Tagged
    1 Thread(s)
    Thanks for the kind words and for having tested the game Jens. Much appreciated!

    I am using Flash Player 13.0.0.182. After some more tests I have noticed that the white screen duration varies a lot depending on the browser used: Firefox, Chrome, Safari, Internet Explorer. With Chrome I have almost no delay. On another computer with Firefox I had almost no delay either. So it really depends on the player's setup. Issue solved... I guess.

    I have checked the "Load on call" property for almost every object. I have also checked the "Force Load On Call option for all objects" property for all the frames. And I have checked the "Load on call" option for all the sounds. But I didn't see any change in the white screen duration. Do these options/properties have any effect on the flash runtime?

Similar Threads

  1. white screen between preloader and game?
    By tompa in forum SWF/Flash Export Module Version 2.0
    Replies: 4
    Last Post: 30th June 2013, 06:34 PM
  2. White Screen Lag
    By ProdigyX in forum Android Export Module Version 2.0
    Replies: 4
    Last Post: 27th November 2011, 04:18 PM
  3. White screen
    By Delano in forum SWF/Flash Export Module Version 2.0
    Replies: 1
    Last Post: 9th November 2011, 03:26 PM
  4. Using preloader = blank white screen
    By RayRayTea in forum SWF/Flash Export Module Version 2.0
    Replies: 12
    Last Post: 18th September 2011, 02:28 PM
  5. White screen
    By Jarzka in forum Hardware Accelerated Runtime
    Replies: 7
    Last Post: 24th April 2009, 09:36 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •