User Tag List

Results 1 to 5 of 5

Thread: Build API, Minimum Android Version, Target Android Version?

  1. #1
    Clicker Fusion 2.5 DeveloperAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleSWF Export Module
    KLiK-iT's Avatar
    Join Date
    Sep 2011
    Location
    New Jersey
    Posts
    2,852
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)

    Build API, Minimum Android Version, Target Android Version?

    What should I be using when it comes to Build API, Minimum Android Version, Target Android Version? I use API 14, Minimum Android Version 2.3/2.3.1/2.3.2 and Target Android Version is 2.3/2.3.1/2.3.2. I don't have any issues as this is working fine on my phone and tablets. Should I do something different or am I ok with what I have been doing?

  2. #2
    Clickteam Clickteam
    Fernando's Avatar
    Join Date
    Dec 2006
    Posts
    6,785
    Mentioned
    298 Post(s)
    Tagged
    4 Thread(s)
    Ok let start from beginning

    Min and target api is the range on where the application can work, see that your application can work above but not below as is set in minimum api.

    So best choice if you want to cover all range and keep the froyo theme is set min 2.3 to 2.3.4 that is froyo and gingerbread, notice that the bar is different and actually in new devices this mode is emulated.

    but if you want to use themes according Honeycomb use the above api set 2.3 to 4.3

    but then if you want to build an use a proper sdk you should use build api 19 which will cover low and bigger apis devices.

    Notice that Android is fixing always error presents in their api so use the latest one could be good and bad, (bad, because some apis had more error than other) but for sure use build 19 is a good choice.

    please read this guide that will explain better what you expect to find in navigation bar, action title or system bar.

    http://community.clickteam.com/threads/84457-A-Guide-to-using-Status-Navigation-bars-Android-Exporter
    Regards,


    Fernando Vivolo

    ... new things are coming ...

  3. #3
    Clicker Fusion 2.5 DeveloperAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleSWF Export Module
    KLiK-iT's Avatar
    Join Date
    Sep 2011
    Location
    New Jersey
    Posts
    2,852
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    This is very confusing. The reason I'm asking is I uploaded an app for the first time to Google Play and it says on the description "Requires Android 2.3 and up"
    All this is very technical to me and I don't understand it whatsoever.

  4. #4
    Clickteam Clickteam
    Fernando's Avatar
    Join Date
    Dec 2006
    Posts
    6,785
    Mentioned
    298 Post(s)
    Tagged
    4 Thread(s)
    well yes, that is to indicate that the minimum version require the device to run your apk is 2.3

    which is correct since you set 2.3

    read the guide it will clarify some ideas.

    sorry for such a mess ideas

    minSdkVersion
    An integer designating the minimum API Level required for the application to run. The Android system will prevent the user from installing the application if the system's API Level is lower than the value specified in this attribute. You should always declare this attribute.
    targetSdkVersion
    An integer designating the API Level that the application is targetting.

    With this attribute set, the application says that it is able to run on older versions (down to minSdkVersion), but was explicitly tested to work with the version specified here. Specifying this target version allows the platform to disable compatibility settings that are not required for the target version (which may otherwise be turned on in order to maintain forward-compatibility) or enable newer features that are not available to older applications. This does not mean that you can program different features for different versions of the platform—it simply informs the platform that you have tested against the target version and the platform should not perform any extra work to maintain forward-compatibility with the target version.

    information from android developer page
    Regards,


    Fernando Vivolo

    ... new things are coming ...

  5. #5
    Clicker Fusion 2.5 DeveloperAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleSWF Export Module
    KLiK-iT's Avatar
    Join Date
    Sep 2011
    Location
    New Jersey
    Posts
    2,852
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    I think I understand how it all works now, thank you very much for your time.

Similar Threads

  1. Get android API version
    By N13astra in forum Android Export Module Version 2.0
    Replies: 0
    Last Post: 14th March 2014, 03:08 AM
  2. Can you monitize Android apps IF YOU DON'T have the developer version?
    By MrPielovin in forum Android Export Module 2.5
    Replies: 10
    Last Post: 10th February 2014, 02:11 AM
  3. Where is Version 2.5 of Android Exporter
    By PunchyBog in forum Android Export Module Version 2.0
    Replies: 8
    Last Post: 16th December 2013, 12:01 PM
  4. Is there an Android version of Xcode's Resources folder?
    By 1234cb in forum Android Export Module Version 2.0
    Replies: 1
    Last Post: 15th June 2013, 05:58 AM
  5. Neon Hidden (android version)
    By Joseclick2011 in forum Android Released Games & Apps
    Replies: 3
    Last Post: 26th April 2013, 01:22 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •