User Tag List

Results 1 to 6 of 6

Thread: App Icon/Launch Image Color Issues - 256 Color Mode

  1. #1
    Clicker Fusion 2.5 DeveloperAndroid Export ModuleiOS Export ModuleSWF Export Module
    JoeRoth12's Avatar
    Join Date
    Feb 2013
    Location
    California
    Posts
    55
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Question App Icon/Launch Image Color Issues - 256 Color Mode

    Hi there.

    My app's icon is a blue pixel dude against a black background. But on my iPad mini, the black turns red. The app is in 256 color mode with color reduction to save memory. I figured the black might be turning transparent, so I tested it with a dark blue background, but it had a weird outline around the dude.

    Here's how it's supposed to look:
    NSIWE - Logo - Large.png

    Here's how the icon looks on my iPad:
    20141116_104744.jpg
    (You can see that the black glasses on my other app icon show up fine.)

    Here's how it looks with a dark blue background instead of black. Note the discolored pixels forming an outline around the dude.
    20141116_105057.jpg

    Any idea what might be going on or how to fix it?

  2. #2
    Clicker Fusion 2.5 DeveloperAndroid Export ModuleiOS Export ModuleSWF Export Module
    JoeRoth12's Avatar
    Join Date
    Feb 2013
    Location
    California
    Posts
    55
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    This might be a clue. I copied the icon from Nerdy Workout to the new game and tested it out, and it became this weird photo-negative. Maybe I have some setting wrong or something?

    20141116_122927.jpg

  3. #3
    Clickteam Clickteam

    Join Date
    Jun 2006
    Location
    France
    Posts
    13,632
    Mentioned
    229 Post(s)
    Tagged
    3 Thread(s)
    >> The app is in 256 color mode with color reduction to save memory.

    iOS doesn't support 256-color images, they are converted to RGB values when CF builds Xcode project (16, 24 or 32 bits, it depends on the image). 256-color might save some space as the color space might be smaller but I think it's not significant.

    Could you send me a simple MFA with the icon so that we take a look?

  4. #4
    Clicker Fusion 2.5 DeveloperAndroid Export ModuleiOS Export ModuleSWF Export Module
    JoeRoth12's Avatar
    Join Date
    Feb 2013
    Location
    California
    Posts
    55
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Sure!

    Not sure if there's a better/built-in way to share MFAs, so I uploaded it to my Squarespace site. Here's the link:
    https://joseph-rothenberg.squarespac...-Icon-Test.mfa

  5. #5
    Clickteam Clickteam

    Join Date
    Jun 2006
    Location
    France
    Posts
    13,632
    Mentioned
    229 Post(s)
    Tagged
    3 Thread(s)
    Looks like it's because your icon has no alpha channel, I'll check if we can fix this automatically or not.

    Edit your icons (and launch images), make sure the background is transparent (fill it with the transparent color otherwise), and then click the Transparency tool, select Alpha channel and answer yes when it asks you if you want to create the alpha channel from the transparent color.

    That should solve the issue.

  6. #6
    Clicker Fusion 2.5 DeveloperAndroid Export ModuleiOS Export ModuleSWF Export Module
    JoeRoth12's Avatar
    Join Date
    Feb 2013
    Location
    California
    Posts
    55
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks, Yves! That seems to work. It'd be nice to have this fix itself automatically in an update (though it's no biggy...there probably aren't too many games made in 256 color mode these days).

Similar Threads

  1. [BUG 256.34] Replace color doesn't always work in standard 256 color mode
    By Corlen in forum Multimedia Fusion 2 - Technical Support
    Replies: 1
    Last Post: 26th October 2014, 10:21 AM
  2. Quick Question - Color Mode and iOS
    By CBSection31 in forum iOS Export Module 2.5
    Replies: 0
    Last Post: 24th July 2014, 09:17 PM
  3. Transparent color not applied when 16bit color mode
    By ASD in forum Multimedia Fusion 2 - Technical Support
    Replies: 0
    Last Post: 25th September 2012, 06:11 AM
  4. Picture editor: color problems in 256 color mode.
    By contra in forum File Archive
    Replies: 5
    Last Post: 13th December 2006, 10:58 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •