User Tag List

Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11

Thread: Active objects leaving a "blur" trail when moving fast

  1. #1
    Clicker Fusion 2.5

    Join Date
    Apr 2012
    Posts
    377
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Active objects leaving a "blur" trail when moving fast

    Hello.

    I'm not sure this is a problem with CF 2.5 itself, or if it's a general principle of graphics.

    As it is now, I'm moving an active object at about 12 pixels each screen re-draw, and I'm feeling that at this speed and above there occurs significant "trailing" of the object, that is it seems to be in more than one place along it's path.
    If I take screenshots using a program such as AnimGet, it's obvious that this is not actually occuring. I've seen other games made with MMF2 where objects appear to be moving at the same speed to my eyes, but this does not seem to occur.

    My application is on 60 FPS, V-Sync is on and Direct3D 9 display mode is being used. Any ideas? Is this all in my mind, or am I missing some secret?

  2. #2
    Forum Moderator Fusion 2.5 DeveloperHTML5 Export ModuleiOS Export ModuleSWF Export Module
    DavidN's Avatar
    Join Date
    Jun 2006
    Location
    Boston, MA, USA
    Posts
    4,044
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    It could be to do with the colour difference between the object and the background, maybe? If you can, can you try it on a different monitor?

  3. #3
    Clicker Fusion 2.5 DeveloperHTML5 Export Module
    serrasoft's Avatar
    Join Date
    Nov 2013
    Location
    Sicily (Italy)
    Posts
    42
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    screen1.jpg

    It is the blend coefficient set to 0 ?

  4. #4
    Clicker Fusion 2.5

    Join Date
    Apr 2012
    Posts
    377
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I believe it is, serrasoft. If I increase it, will the behavior disappear?

  5. #5
    Clicker Fusion 2.5 DeveloperHTML5 Export Module
    serrasoft's Avatar
    Join Date
    Nov 2013
    Location
    Sicily (Italy)
    Posts
    42
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Active objects leaving a "blur" trail when moving fast

    Sorry for my terrible english, I'm Italian. Sometimes ago I, by distraction, leave the blend coefficient of an active object to a value <>0, and I see the blur trail, and when I put the value again to 0, the trail disappear

  6. #6
    Clicker Fusion 2.5

    Join Date
    Apr 2012
    Posts
    377
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Ah. Well, it's not really a "blur " trail, it's more that the object seems to be in more than one place?

  7. #7
    Clicker Fusion 2.5
    Warmachine's Avatar
    Join Date
    Nov 2009
    Location
    Charleston, WV
    Posts
    653
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    When you say Re-draw, are you talking about creating another of the same object? The reason why i ask is if that's the case you may just be seeing duplicates of the object being created while its moving. Thats how i do my pseudo onion skin lol, its a cheap way to do it but it works

  8. #8
    Clicker Fusion 2.5

    Join Date
    Apr 2012
    Posts
    377
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Sorry no, what I mean by re-draw is the whole frame being drawn. I'm using fastloops to move the object 20 pixels each frame, and the eye can barely follow the object. Meanwhile, in for example Noitu Love 2 which was made with Multimedia Fusion 2, if you fire an energy ball it moves 20 pixels each frame but you can follow it with the eye quite easily. I don't know if it's due to the colors being used and it's an optical illusion, or what might be the cause.

  9. #9
    Clicker Fusion 2.5 DeveloperAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleUniversal Windows Platform Export ModuleSWF Export Module
    Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)
    DaveC's Avatar
    Join Date
    Jun 2007
    Location
    Perth, Australia
    Posts
    2,112
    Mentioned
    13 Post(s)
    Tagged
    0 Thread(s)
    I believe the official term is called 'Screen Tearing' - http://en.wikipedia.org/wiki/Screen_tearing

    "Screen tearing is a visual artifact in video display where a display device shows information from two or more frames in a single screen draw. Tearing can occur with most common display technologies and video cards, and is most noticeable in horizontally-moving visuals, such as in slow camera pans in a movie, or classic side-scrolling video games."

    You might find some more info if you search around the forum using that term.
    http://community.clickteam.com/threads/84526-Jerky-Scrolling-tried-everything?highlight=tearing

    I'd make sure your Fusion 2.5 is up to date, then I can only recommend you experiment with various display modes / window size / colour depth etc. to see if there's any combination where you can't see the problem. It could be a video driver thing.. I know I used to have this problem but with the integration of the HWA into the runtime I think I haven't noticed it since.

    Edit. One other thing to try is put your scrolling event (eg. always center of bullet) on the very last line of your code to see if that makes a difference!

  10. #10
    Clicker Fusion 2.5

    Join Date
    Apr 2012
    Posts
    377
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hello DaveC, thanks for the answer! This is not the problem I'm having though, I guess it's kind of hard to explain? The camera is stationary, the object is moving. The object moving is being launched at 20 pixels per frame, but the camera remains still.

Page 1 of 2 1 2 LastLast

Similar Threads

  1. Proper Colorize, leaving "whites" white
    By ffomega in forum Fusion 2.5
    Replies: 3
    Last Post: 5th December 2014, 01:48 AM
  2. change "active" rectangle color with "Color selector". help
    By Sevennemesis in forum Multimedia Fusion 2 - Technical Support
    Replies: 1
    Last Post: 24th February 2013, 01:40 AM
  3. "Caret" problems with the Rich Edit Object/Fast Loop Question
    By Gullyking in forum Multimedia Fusion 2 - Technical Support
    Replies: 0
    Last Post: 4th June 2012, 04:41 AM
  4. Determine distance from objects ("A" to "B")
    By Oreo in forum Multimedia Fusion 2 - Technical Support
    Replies: 3
    Last Post: 4th April 2010, 02:47 AM
  5. Option to "Blur" the entire screen
    By Bornemix in forum Multimedia Fusion 2 - Technical Support
    Replies: 6
    Last Post: 27th October 2009, 02:38 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •