User Tag List

Results 1 to 3 of 3

Thread: problem with animation functions

  1. #1
    No Products Registered

    Join Date
    Oct 2014
    Posts
    38
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    problem with animation functions

    Hey guys! I have this little annoyance. I have this hornet enemy class connected to a list, with a counter in-between. I just have this system set up simply to select a hornet at random and have him fire at the player. So there is a list and a counter; the counter picks a value randomly from the list. Also each hornet has an alterable value, that gets spread. Well, lol. I'll just post an image of this system. It's not complicated, I'm just a klutz and explaining it. The problem is, in line 82. Everything works fine. The hornet is chosen, the hornet stops, waits, fires a venom missile, then keeps moving. But in line 82 it says that it's animation should change to hint. But it's animation won't change to "hint". Which is really annoying. The only other piece of information maybe I should enter, is that the alterable variable "Legs On Off = 1" stops the hornets movement. And "Legs On Off = 0" resumes his movement. Does anyone have any ideas about why all of these other events and conditions work, but his animation won't change?

    http://imgur.com/Lqt5ZdJ

  2. #2
    No Products Registered

    Join Date
    Oct 2014
    Posts
    38
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    here's an image for the "motion controls" for the Legs On/Off alterable values. I'm not sure if that helps, but... maybe it does.

    http://imgur.com/OcaPFRf

  3. #3
    No Products Registered

    Join Date
    Oct 2014
    Posts
    38
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I solved it!! It took about four or five days but I solved it. I just wanted to say thanks to all who took the time out to read this thread. Basically there was nothing wrong with line 82 or any of those lines. The code was working perfectly; and the hornet WAS hinting. I must've scanned those lines for hours and hours. Trying to figure out what I did wrong. Perhaps an ordering problem? I didn't know until now. pretty much the problem was in his animation directions. Only his left "hint" animation direction was different. The top, right and bottom "hint" animations were the same as the top, right, and bottom "stopped" animations. So he would really be setting to his hint animation. but I couldn't tell because those animations looked identical. Whew. That sure was annoying. I suppose you can't only watch your events and conditions; but also make sure that your objects have the right alterable values and the right animations in the right directions. I suppose you pretty much have you make sure EVERYTHING is correct. lol. Anyway, I really want to just thank everyone, who took the time out to read this thread.

Similar Threads

  1. Problem with animation
    By Brosephus in forum Multimedia Fusion 2 - Technical Support
    Replies: 2
    Last Post: 4th March 2013, 02:00 PM
  2. animation problem
    By brett in forum SWF/Flash Export Module Version 2.0
    Replies: 8
    Last Post: 22nd October 2011, 08:08 AM
  3. animation problem
    By iammfa in forum Multimedia Fusion 2 - Technical Support
    Replies: 1
    Last Post: 2nd May 2009, 01:32 PM
  4. animation problem
    By gamemaking in forum Multimedia Fusion 2 - Technical Support
    Replies: 4
    Last Post: 2nd July 2008, 07:54 PM
  5. Problem with MMF2 trig functions...
    By Mr_Monkey in forum Multimedia Fusion 2 - Technical Support
    Replies: 3
    Last Post: 1st April 2007, 03:23 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •