User Tag List

Results 1 to 9 of 9

Thread: Requires the iOS7 SDK or greater

  1. #1
    Clicker Fusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleUniversal Windows Platform Export ModuleSWF Export ModuleXNA Export Module
    Outcast's Avatar
    Join Date
    Jan 2011
    Location
    Sweden
    Posts
    3,156
    Mentioned
    9 Post(s)
    Tagged
    0 Thread(s)

    Question Requires the iOS7 SDK or greater

    I have not been building for iOS for a while and I noticed a message I have not got before when building my latest zip "Warning: this version of the iOS export module requires the iOS7 SDK or greater"

    Does this mean I will not be able to test it on my ipod 4 that I think only can run iOS6? (I know apple will have new requirements for 64bit and iOS8 if I am not mistaken by february)

    If so what is the newest version of the extension I can downgrade to be able to run it?

    Also a follow up question, I also have an iPhone 4, I assume that also only can run iOS6?

    And another follow up question, if this is the case I guess I need to buy a new device (thanks apple) so what is the recommended device to buy at this point? I want a low end device since I like to test against the lowest possible performance to be safe that the app runs well on all devices.

  2. #2
    Clicker Fusion 2.5 DeveloperAndroid Export ModuleiOS Export ModuleSWF Export ModuleInstall Creator ProPatch Maker

    Join Date
    Jun 2006
    Location
    Norway
    Posts
    528
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I think you just need the latest version of xcode.

    If I'm wrong, the previous version should work fine, Build 282.3

    iPod 4 supports 6.1.6, while iPhone4 supports 7.1.2 (http://en.wikipedia.org/wiki/List_of_iOS_devices)

    The iPhone4 or 3GS is a nice low end device

  3. #3
    Clicker Fusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleUniversal Windows Platform Export ModuleSWF Export ModuleXNA Export Module
    Outcast's Avatar
    Join Date
    Jan 2011
    Location
    Sweden
    Posts
    3,156
    Mentioned
    9 Post(s)
    Tagged
    0 Thread(s)
    This is the message I got from Apple "Beginning February 1, 2015 new iOS apps submitted to the App Store must include 64-bit support and be built with the iOS 8 SDK. "

    Does that not mean I will need to buy a device that supports 8? (If Iphone4 only supports 7?)

  4. #4
    Clicker Fusion 2.5 DeveloperAndroid Export ModuleiOS Export ModuleSWF Export ModuleInstall Creator ProPatch Maker

    Join Date
    Jun 2006
    Location
    Norway
    Posts
    528
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I am pretty sure that just means all new apps as of January 1st must support 64 bit and built with the latest SDK. I think this just means the apps will run better on the newer devices that supports 64 bit.
    I believe the iPhone 5S and newer are the only ones with 64 bit support, I am pretty sure apple won't bottlenect all new apps down to the iPhone 5S

    Here's an article about 32 vs 64 bit devices:
    http://www.pcadvisor.co.uk/features/...32-bit-iphone/

  5. #5
    Clicker Fusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleUniversal Windows Platform Export ModuleSWF Export ModuleXNA Export Module
    Outcast's Avatar
    Join Date
    Jan 2011
    Location
    Sweden
    Posts
    3,156
    Mentioned
    9 Post(s)
    Tagged
    0 Thread(s)
    So you think I can continue to use my Ipod 4 for testing?

  6. #6
    Clicker Fusion 2.5 DeveloperAndroid Export ModuleiOS Export ModuleSWF Export ModuleInstall Creator ProPatch Maker

    Join Date
    Jun 2006
    Location
    Norway
    Posts
    528
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I am guessing that won't be a problem.
    I haven't tested xcode 6 yet, but I think you can install earlier iOS libraries, at least you could for xcode 5: http://stackoverflow.com/questions/1...6-with-xcode-5

  7. #7
    Clickteam Clickteam
    Anders's Avatar
    Join Date
    Jun 2006
    Location
    Denmark, ┼rhus
    Posts
    3,455
    Mentioned
    2 Post(s)
    Tagged
    1 Thread(s)
    The iOS exporter now supports both 64bit and 32bit. When compiling it actually compiles for both architectures - meaning that new devices will run the 64bit version and older devices will run the 32bit version. It all happens automatically and you don't have to worry about it

  8. #8
    Clicker

    Fusion 2.5 MacFusion 2.5 DeveloperAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleSWF Export ModuleInstall Creator ProUnicode Add-on
    StingRay's Avatar
    Join Date
    Nov 2006
    Location
    Austria
    Posts
    1,020
    Mentioned
    5 Post(s)
    Tagged
    0 Thread(s)
    great news, Anders! just a question about older apps. if i have an update for a Fusion 2 App where i just have to change the .cci file and upload a new version,
    is there a way to keep this simple method? or is there no way around to export the project completly fresh from fusion 2.5? thanks for the info!

  9. #9
    Clickteam Clickteam
    Anders's Avatar
    Join Date
    Jun 2006
    Location
    Denmark, ┼rhus
    Posts
    3,455
    Mentioned
    2 Post(s)
    Tagged
    1 Thread(s)
    I'm afraid you have to do a fresh export from Fusion and port over your manual changes.
    If you are unsure of what you changed in the codebase yourself then compare a fresh export of the old iOS exporter version with your current project with http://winmerge.org/
    There you can see exactly what was modified.

    Then update the iOS exporter, do a fresh export and copy over whatever changes you made.

Similar Threads

  1. Mavericks and ios7 problem
    By brett in forum iOS Export Module 2.5
    Replies: 4
    Last Post: 21st February 2014, 04:02 PM
  2. Bugs iOS7 report
    By Koji_Kabuto in forum iOS Export Module Version 2.0
    Replies: 12
    Last Post: 30th October 2013, 03:27 PM
  3. Problem installing beta (Ad-hoc) on iOS7
    By Yos in forum iOS Export Module Version 2.0
    Replies: 7
    Last Post: 20th October 2013, 12:16 PM
  4. ios7 and ini
    By Raudaschl in forum iOS Export Module Version 2.0
    Replies: 9
    Last Post: 27th June 2013, 08:54 PM
  5. Edit Box requires different input
    By alternatepower in forum Multimedia Fusion 2 - Technical Support
    Replies: 0
    Last Post: 9th August 2007, 02:33 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •