User Tag List

Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12

Thread: Fullscreen or "filling screen" messes with my Active System object buttons....

  1. #1
    Clicker Fusion 2.5 Developer
    JohnZ's Avatar
    Join Date
    Jul 2006
    Posts
    140
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    Question Fullscreen or "filling screen" messes with my Active System object buttons....

    Hi there

    Fullscreen or "filling screen" messes with my Active System object buttons and Edit boxes. The mouse actions only happen on a few of the buttons, and it's random at best. Is like my mouse is not at the right co-ordinates or something.

    On fullscreen, my edit boxes do not show at all. Neither do my 'colour selecter' buttons

    I've tried various combinations of of settings in the app properties but nothing i'm doing works.

    Any suggestions?

    Attached is what it looks like before going fullscreen and after

    Cheers
    J
    Images attachées Images attachées

  2. #2
    Clicker Fusion 2.5 Developer

    Join Date
    Jan 2015
    Posts
    36
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I think this is just a problem with using windows objects. You can make your own buttons with actives and its fine. Kind of sucks

  3. #3
    Clicker Fusion 2.5 Developer
    JohnZ's Avatar
    Join Date
    Jul 2006
    Posts
    140
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Thanks for the reply.

    Doesn't help with the edit boxes

  4. #4
    Clicker Fusion 2.5 Developer

    Join Date
    Jan 2015
    Posts
    36
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Yeah I don't know actually. I used to get this problem with one of my frames, but I just tried it again and its not doing it anymore. I'm assuming I changed some magical option in the application properties at some point. Can't seem to figure it out

  5. #5
    Clicker Fusion 2.5 Developer
    JohnZ's Avatar
    Join Date
    Jul 2006
    Posts
    140
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Interesting - can you tell me exactly what settings you have? Are you using 'standard' mode or DD modes? What else have you got ticked in the display options?
    Cheers
    J

  6. #6
    Clicker Fusion 2.5 Developer
    JohnZ's Avatar
    Join Date
    Jul 2006
    Posts
    140
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Is there a programming explanation why I'm getting these results? Be good to know if there definitely is no work around.

  7. #7
    Clicker Fusion 2.5 Developer

    Join Date
    Jan 2015
    Posts
    36
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I messed around with it a bit and I found out by using the actual fullscreen mode all the windows objects seem to not properly move/resize with the window. If you use the proper application setting then maximizing the window seems to perform the same function and the windows objects behave a lot better. The color select still doesn't cooperate

    window sizing.mfa

  8. #8
    Clickteam Clickteam

    Join Date
    Jun 2006
    Location
    France
    Posts
    12,917
    Mentioned
    94 Post(s)
    Tagged
    2 Thread(s)
    For info the problem with the ASB object is fixed in the next build: http://bugbox.clickteam.com/issues/1809

    The problem with the Edit box is that in full screen Direct3D mode the controls (or more generally all the objects with their own window) are not displayed (they don't support multiple screen flipping). Workaround: put an edit object out of the frame, put a string object in the frame, set the content of the string object to the content of the edit object and when the user clicks the string set the focus to the edit object.

  9. #9
    Clicker Fusion 2.5 Developer
    JohnZ's Avatar
    Join Date
    Jul 2006
    Posts
    140
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Bobjuzz, thanks for your help!

  10. #10
    Clicker Fusion 2.5 Developer
    JohnZ's Avatar
    Join Date
    Jul 2006
    Posts
    140
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Thanks Yves

Page 1 of 2 1 2 LastLast

Similar Threads

  1. Fullscreen mode is showing "black bars"
    By CRKFIEND in forum Fusion 2.5
    Replies: 2
    Last Post: 15th January 2015, 01:51 PM
  2. Replies: 3
    Last Post: 14th October 2014, 11:24 PM
  3. Need help. "True black" colour not shown in fullscreen mode.
    By Kazuya in forum Multimedia Fusion 2 - Technical Support
    Replies: 0
    Last Post: 7th January 2014, 06:51 AM
  4. Surface Object: Take "screenshot" of section on screen
    By Bipolar_Games in forum Multimedia Fusion 2 - Technical Support
    Replies: 6
    Last Post: 4th March 2013, 05:24 PM
  5. [BUG RC1] ScreenHeight("Android object") is not actual screen height
    By Bipolar_Games in forum Android Export Module Version 2.0
    Replies: 0
    Last Post: 11th October 2012, 06:56 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •