User Tag List

Results 1 to 8 of 8

Thread: AdMob + Export android = Error

  1. #1
    Clicker Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)

    Join Date
    Dec 2014
    Posts
    4
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Exclamation AdMob + Export android = Error

    Added to the project unit AdMob and the game ceases to gather under the android

    The last line of the Makefile:
    Code:
    D:\andro_sdk\jdt\sdk\tools\ant\build.xml:601: The following error occurred while executing this line:
    D:\andro_sdk\jdt\sdk\tools\ant\build.xml:542: Unable to resolve project target 'android-10'
    It is necessary to remove the module and project collects fine. Already tried and different API, and different jdk. The error is the same

  2. #2
    Clickteam Clickteam
    Jeff's Avatar
    Join Date
    Jun 2006
    Location
    Battle Ground Washington
    Posts
    11,825
    Mentioned
    8 Post(s)
    Tagged
    2 Thread(s)
    You need to use a newer API -- It looks like your trying to use 10
    Change your application property and try a newer API.

    I think you have to use 14 or newer to use Admob


    Edit just did a test with API 21 -- APK built without errors.

  3. #3
    Clickteam Clickteam

    Join Date
    Jun 2006
    Location
    France
    Posts
    14,107
    Mentioned
    279 Post(s)
    Tagged
    3 Thread(s)
    Since the build 284 you need to also install API #10 in the SDK if you use Admob (don't change the API you use to build app, just install API #10 in the Android SDK).

  4. #4
    Clickteam Clickteam
    Jeff's Avatar
    Join Date
    Jun 2006
    Location
    Battle Ground Washington
    Posts
    11,825
    Mentioned
    8 Post(s)
    Tagged
    2 Thread(s)
    Interesting I will have to remember that.

    So you need API 10 but you should build with API 14 or newer?

  5. #5
    Clickteam Clickteam

    Join Date
    Jun 2006
    Location
    France
    Posts
    14,107
    Mentioned
    279 Post(s)
    Tagged
    3 Thread(s)
    Yes, that's correct.

  6. #6
    No Products Registered

    Join Date
    May 2016
    Posts
    13
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hey there! Sorry to come to an old post. I am getting the same error, but I can't install API 10. It says it is not compatible with Windows. How do you get around this?

  7. #7
    Clickteam Clickteam
    Jeff's Avatar
    Join Date
    Jun 2006
    Location
    Battle Ground Washington
    Posts
    11,825
    Mentioned
    8 Post(s)
    Tagged
    2 Thread(s)
    Look here: http://community.clickteam.com/threads/97050-Cant-get-ADMOB-and-CHARTBOOST-to-work?p=692416&viewfull=1#post692416

    Fernando is changing this so it won't require API 10 anymore here soon.

    Also you should register your Steam profile or serial number so you can get the latest beta version (or at least learn about them if your on Steam)
    Do this under the Community Passport link on the forum header.

  8. #8
    No Products Registered

    Join Date
    May 2016
    Posts
    13
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks a lot. Will do that soon.

Similar Threads

  1. Android export fatal error
    By SoftWarewolf in forum Android Export Module 2.5
    Replies: 10
    Last Post: 21st August 2014, 11:38 AM
  2. Error Installing Android export module for 2.5, Server is busy
    By Keristero in forum Android Export Module 2.5
    Replies: 4
    Last Post: 6th July 2014, 09:59 PM
  3. android export module freeze by export a program
    By chrissk in forum Android Export Module 2.5
    Replies: 4
    Last Post: 4th March 2014, 03:37 PM
  4. Setting up the Android SDK for the Android Export Module
    By Jeff in forum Android Export Module Version 2.0
    Replies: 3
    Last Post: 2nd October 2013, 04:08 PM
  5. SWF EXPORT ERROR
    By imothep85 in forum SWF/Flash Export Module Version 2.0
    Replies: 13
    Last Post: 25th September 2010, 03:39 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •