User Tag List

Results 1 to 3 of 3

Thread: shooting stopped working glitch

  1. #1
    No Products Registered

    Join Date
    Jul 2014
    Posts
    9
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    shooting stopped working glitch

    hey guys, I was making a game today and I had it set so that the character would be able to shoot projectiles. usual, but I was testing it and I saw that if you keep pressing it it stops letting you shoot altogether. if you have any solution please let me know.

  2. #2
    Clicker Fusion 2.5

    Join Date
    Dec 2009
    Posts
    63
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Check your frame properties --> Runtime options --> number of objects - default is 500, try increasing this.
    Also, how have you programmed the shooting of projectiles? If you haven't added some sort of delay, i.e you just coded FIRE BUTTON PRESSED -->launch projectile, then you after a few seconds you've launched so many that once you go over the frame's object limit, you can't create (launch) any more.
    Try adding EVERY 15/100 secs + FIRE BUTTON PRESSED --> launch projectile, or even better use a cool-down counter.

  3. #3
    No Products Registered

    Join Date
    Jul 2014
    Posts
    9
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    ok, it's fixed now, but I also have another probem, I tried making so that when you get a certain item, you get another object to follow you like in gradius or other shoot em ups when you get a second ship, but it crashes whenever it's collected, I have it set to where it's not visible from start and always set at a certain disatnce from the player and fires whenever you press the fire button, but it only shoots when visible. and getting the item is supposed to make it visible, but instead it crashes the game.

Similar Threads

  1. edrt.exe has stopped working
    By adeb in forum Fusion 2.5
    Replies: 7
    Last Post: 15th December 2015, 01:25 PM
  2. Scrolling has stopped working...
    By jaytmek in forum Fusion 2.5
    Replies: 1
    Last Post: 21st February 2015, 07:45 PM
  3. "aapt.exe has stopped working" - build not working as android application
    By thlipply in forum Android Export Module 2.5
    Replies: 10
    Last Post: 24th October 2014, 04:16 AM
  4. Animations stopped working
    By tjmhoops in forum Android Export Module 2.5
    Replies: 14
    Last Post: 17th May 2014, 08:55 PM
  5. Transitions stopped working?
    By Corlen in forum Multimedia Fusion 2 - Technical Support
    Replies: 5
    Last Post: 21st September 2010, 07:28 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •