User Tag List

Page 5 of 5 FirstFirst ... 3 4 5
Results 41 to 44 of 44

Thread: SETUP Android SDK/ JAVA JDK - How to export to android - Tutorial

  1. #41
    Clickteam Clickteam
    Fernando's Avatar
    Join Date
    Dec 2006
    Posts
    5,738
    Mentioned
    95 Post(s)
    Tagged
    2 Thread(s)
    more information is need

    1.- what fusion version you are using?

    2.- are you using input type without edit object, they work as paired so when using input type edit object must exist

    3.- did you update the android sdk tools to something close to 28 instead of
    Android SDK Tools Revision 25.2.5
    Regards,


    Fernando Vivolo

    ... new things are coming ...

  2. #42
    Clicker Fusion 2.5Android Export ModuleHTML5 Export ModuleSWF Export Module
    xDeeringx's Avatar
    Join Date
    Dec 2013
    Posts
    27
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by Fernando View Post
    more information is need

    1.- what fusion version you are using?

    2.- are you using input type without edit object, they work as paired so when using input type edit object must exist

    3.- did you update the android sdk tools to something close to 28 instead of
    Android SDK Tools Revision 25.2.5
    1. 291.6

    2. no just the android input type <= I'll eliminate it and see if that helps

    3. yes.


    Update: eliminated the android input type and was able to build. Thank you for the insight

  3. #43
    Clicker Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)

    Join Date
    Sep 2017
    Posts
    12
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks for this video. I'm getting the following error message when I try to build. Apparently I've done something wrong regarding Java. Any advice for me?:

    Buildfile: C:\Users\ROBBEN~1\AppData\Local\Temp\AndC72D.tmp\b uild.xml

    -set-mode-check:

    -set-release-mode:

    -release-obfuscation-check:
    [echo] proguard.config is ${proguard.config}

    -pre-build:

    -check-env:
    [checkenv] Android SDK Tools Revision 25.2.5
    [checkenv] Installed at C:\Users\ROb Bentley\AppData\Local\Android\android-sdk

    -setup:
    [echo] Project Name: RuntimeAndroid
    [gettype] Project Type: Application

    -build-setup:
    [getbuildtools] Using latest Build Tools: 28.0.3
    [echo] Resolving Build Target for RuntimeAndroid...
    [gettarget] Project Target: Android 8.1.0
    [gettarget] API level: 27
    [echo] ----------
    [echo] Creating output directories if needed...
    [mkdir] Created dir: C:\Users\ROBBEN~1\AppData\Local\Temp\AndC72D.tmp\b in
    [mkdir] Created dir: C:\Users\ROBBEN~1\AppData\Local\Temp\AndC72D.tmp\b in\res
    [mkdir] Created dir: C:\Users\ROBBEN~1\AppData\Local\Temp\AndC72D.tmp\b in\rsObj
    [mkdir] Created dir: C:\Users\ROBBEN~1\AppData\Local\Temp\AndC72D.tmp\b in\rsLibs
    [mkdir] Created dir: C:\Users\ROBBEN~1\AppData\Local\Temp\AndC72D.tmp\g en
    [mkdir] Created dir: C:\Users\ROBBEN~1\AppData\Local\Temp\AndC72D.tmp\b in\classes
    [mkdir] Created dir: C:\Users\ROBBEN~1\AppData\Local\Temp\AndC72D.tmp\b in\dexedLibs
    [echo] ----------
    [echo] Resolving Dependencies for RuntimeAndroid...
    [dependency] Library dependencies:
    [dependency] No Libraries
    [dependency]
    [dependency] ------------------
    [echo] ----------
    [echo] Building Libraries with 'release'...
    [subant] No sub-builds to iterate on

    -code-gen:
    [mergemanifest] Merging AndroidManifest files into one.
    [mergemanifest] Manifest merger disabled. Using project manifest only.
    [echo] Handling aidl files...
    [aidl] No AIDL files to compile.
    [echo] ----------
    [echo] Handling RenderScript files...
    [echo] ----------
    [echo] Handling Resources...
    [aapt] Generating resource IDs...
    [echo] ----------
    [echo] Handling BuildConfig class...
    [buildconfig] Generating BuildConfig class.

    -pre-compile:

    -compile:
    [javac] Compiling 416 source files to C:\Users\ROBBEN~1\AppData\Local\Temp\AndC72D.tmp\b in\classes
    [javac] error: Source option 5 is no longer supported. Use 6 or later.
    [javac] error: Target option 1.5 is no longer supported. Use 1.6 or later.

    BUILD FAILED
    C:\Users\ROb Bentley\AppData\Local\Android\android-sdk\tools\ant\build.xml:716: The following error occurred while executing this line:
    C:\Users\ROb Bentley\AppData\Local\Android\android-sdk\tools\ant\build.xml:730: Compile failed; see the compiler error output for details.

    Total time: 2 seconds

  4. #44
    Clickteam Clickteam
    Fernando's Avatar
    Join Date
    Dec 2006
    Posts
    5,738
    Mentioned
    95 Post(s)
    Tagged
    2 Thread(s)
    update your sdk tools is too old "
    Android SDK Tools Revision 25.2.5
    "
    Regards,


    Fernando Vivolo

    ... new things are coming ...

Page 5 of 5 FirstFirst ... 3 4 5

Similar Threads

  1. Replies: 56
    Last Post: 26th December 2017, 08:53 PM
  2. Can Fusion and Android Export Module create Android Live Wallpapers?
    By chickenlump in forum Android Export Module 2.5
    Replies: 5
    Last Post: 4th September 2015, 09:29 PM
  3. Setting up the Android SDK for the Android Export Module
    By Jeff in forum Android Export Module Version 2.0
    Replies: 3
    Last Post: 2nd October 2013, 04:08 PM
  4. Setting up the Android SDK for the Android Export Module
    By Jeff in forum Android Export Module 2.5
    Replies: 3
    Last Post: 2nd October 2013, 04:08 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •