User Tag List

Page 1 of 2 1 2 LastLast
Results 1 to 10 of 19

Thread: Get Object not working with HTTP

  1. #1
    Clicker Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Fusion 2.5+ DLC (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)

    Join Date
    May 2017
    Location
    Nantes
    Posts
    115
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)

    Exclamation Get Object not working with HTTP

    Hello,

    Get object is not working with HTTP adresses.
    I tried the get object example given with fusion, and still have the same problem.

    When launching the android app in windows, every thing works fine (http and https), but when running it in an android emulator or a real android phone, only https adresses work.
    The object doesn't give any response if it's an http adresse.

    Can you please check and fix ?

    fusion 2.5+ steam 292.10
    Android selected api 29

    thanks,
    Haoujey

  2. #2
    Clickteam Clickteam
    Fernando's Avatar
    Join Date
    Dec 2006
    Posts
    6,248
    Mentioned
    177 Post(s)
    Tagged
    3 Thread(s)
    please post a small mfa that reproduce this issue

    and more important what device specs you are testing this.

    android is moving to security links as is done in html5
    Regards,


    Fernando Vivolo

    ... new things are coming ...

  3. #3
    Clicker Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Fusion 2.5+ DLC (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)

    Join Date
    May 2017
    Location
    Nantes
    Posts
    115
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    you can reproduce the behavior with the get object example mfa provided with fusion. And use the http and https adresses in the drop down list.

    I'm testing on nexus 5x emulator with android 9 api 29.
    And my phone is a Mate9 with android 9

  4. #4
    Clickteam Clickteam
    Fernando's Avatar
    Join Date
    Dec 2006
    Posts
    6,248
    Mentioned
    177 Post(s)
    Tagged
    3 Thread(s)
    yes http is blocked because security rules by android, let me see if i can do some changes in GET object for this to work with http.

    =========================

    you still can build with API 28 as google request in store and seems to work. please test there with device with version 9, here seems OK.
    Regards,


    Fernando Vivolo

    ... new things are coming ...

  5. #5
    Clicker Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Fusion 2.5+ DLC (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)

    Join Date
    May 2017
    Location
    Nantes
    Posts
    115
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    i compiled the get example mfa with api 28, and deploy it on an android 9 emulator and i still have the same behaviour.
    Https adresses (google.com ) responds but http doesn't do anything.

  6. #6
    Clickteam Clickteam
    Fernando's Avatar
    Join Date
    Dec 2006
    Posts
    6,248
    Mentioned
    177 Post(s)
    Tagged
    3 Thread(s)
    mm, no in real device though
    Regards,


    Fernando Vivolo

    ... new things are coming ...

  7. #7
    Clicker Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Fusion 2.5+ DLC (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)

    Join Date
    May 2017
    Location
    Nantes
    Posts
    115
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    sorry didn't understood your request.
    I made a second test on my Mate 9 with the apk generated before and still the same behaviour. No reaction when testing an http. Even the counter on the top right corner doesn't change.
    But when i use an https link, all works ok.

  8. #8
    Clickteam Clickteam
    Fernando's Avatar
    Join Date
    Dec 2006
    Posts
    6,248
    Mentioned
    177 Post(s)
    Tagged
    3 Thread(s)
    mm here it worked, does this huawei have EMU, if so what version?

    huawei is a mistery somehow with some features
    Regards,


    Fernando Vivolo

    ... new things are coming ...

  9. #9
    Clicker Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Fusion 2.5+ DLC (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)

    Join Date
    May 2017
    Location
    Nantes
    Posts
    115
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    yes EMU 9.0.1.191 (C432)

  10. #10
    Clicker Fusion 2.5 DeveloperAndroid Export ModuleiOS Export ModuleInstall Creator Pro

    Join Date
    Feb 2014
    Posts
    32
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    @Fernando could this be a solution to the problem?

    https://medium.com/mindorks/my-netwo...e-7c7a31e33330

Page 1 of 2 1 2 LastLast

Similar Threads

  1. Replies: 0
    Last Post: 10th February 2015, 02:29 PM
  2. HTTP request
    By Pompos in forum Fusion 2.5
    Replies: 5
    Last Post: 11th April 2014, 12:18 AM
  3. HTTP Downloader Object?
    By Darkhog in forum Extension Development
    Replies: 2
    Last Post: 26th February 2009, 11:50 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •