User Tag List

Page 4 of 5 FirstFirst ... 2 3 4 5 LastLast
Results 31 to 40 of 47

Thread: SETUP Android SDK/ JAVA JDK - How to export to android - Tutorial

  1. #31
    Clicker Fusion 2.5 MacAndroid Export ModuleiOS Export Module
    Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Fusion 2.5+ DLC (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)

    Join Date
    Dec 2016
    Posts
    187
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    This video has all links and information for setting up the Android exporter

    https://youtu.be/HUcmePD7o9Q

  2. #32
    Clicker Fusion 2.5 MacAndroid Export ModuleiOS Export Module
    Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Fusion 2.5+ DLC (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)

    Join Date
    Dec 2016
    Posts
    187
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    That includes the old Android sdk that's easy to use.

  3. #33
    Clicker Fusion 2.5 MacFusion 2.5 DeveloperFusion 2.5 DeveloperAndroid Export ModuleiOS Export ModuleMac Export Module

    Join Date
    Jun 2018
    Posts
    14
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    hi guys i have macbook, i use high sirea

    i cant create APK. what can i do. i see that eror message:


    Apache Ant(TM) version 1.9.4 compiled on April 29 2014
    Trying the default build file: build.xml
    Buildfile: /Applications/Clickteam Fusion 2.5.app/Contents/Resources/drive_c/users/Wineskin/Temp/And4c58.tmp/build.xml
    Detected Java version: 1.9 in: /Library/Java/JavaVirtualMachines/jdk-10.0.2.jdk/Contents/Home
    Detected OS: Mac OS X
    parsing buildfile /Applications/Clickteam Fusion 2.5.app/Contents/Resources/drive_c/users/Wineskin/Temp/And4c58.tmp/build.xml with URI = file:/Applications/Clickteam%20Fusion%202.5.app/Contents/Resources/drive_c/users/Wineskin/Temp/And4c58.tmp/build.xml
    Project base dir set to: /Applications/Clickteam Fusion 2.5.app/Contents/Resources/drive_c/users/Wineskin/Temp/And4c58.tmp
    parsing buildfile jar:file:/Applications/Clickteam%20Fusion%202.5.app/Contents/Resources/drive_c/Program%20Files/Clickteam%20Fusion%202.5/Data/Runtime/Android/apache-ant/lib/ant.jar!/org/apache/tools/ant/antlib.xml with URI = jar:file:/Applications/Clickteam%20Fusion%202.5.app/Contents/Resources/drive_c/Program%20Files/Clickteam%20Fusion%202.5/Data/Runtime/Android/apache-ant/lib/ant.jar!/org/apache/tools/ant/antlib.xml from a zip file
    [property] Loading /Applications/Clickteam Fusion 2.5.app/Contents/Resources/drive_c/users/Wineskin/Temp/And4c58.tmp/ant.properties
    Importing file /Users/cemberber/Library/Android/sdk/tools/ant/build.xml from /Applications/Clickteam Fusion 2.5.app/Contents/Resources/drive_c/users/Wineskin/Temp/And4c58.tmp/build.xml

  4. #34
    Clickteam Clickteam
    Fernando's Avatar
    Join Date
    Dec 2006
    Posts
    6,318
    Mentioned
    206 Post(s)
    Tagged
    4 Thread(s)
    mm you shoudl be using java 1.8 and android sdk with ant builder this should do https://android-sdk.en.softonic.com/
    Regards,


    Fernando Vivolo

    ... new things are coming ...

  5. #35
    Clicker Fusion 2.5 DeveloperAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleSWF Export Module
    Simflare's Avatar
    Join Date
    Oct 2013
    Location
    Australia
    Posts
    374
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    What is the highest API of the Android SDK Fusion supports at the moment? I haven't updated my app in a while, but Google just sent me an email saying that apps are required to target Android Oreo(API 26) or higher soon, and mine only targets API 14. It said new apps won't be allowed to be submitted that don't support API 26, and it also sounds like apps that target older API's might be removed from the store. Or it might just not let me update in future, not sure yet.

    Any answers to the latest supported API?

    Edit: Reading further on the official post, it sounds like they won't take down old apps, but only prevent updates from apps that or new apps that don't target the latest API.

    It also sounds like new apps will be forced to be 64-bit, like iOS did a while back. Can Fusion support this now also?

  6. #36
    Clickteam Clickteam
    Fernando's Avatar
    Join Date
    Dec 2006
    Posts
    6,318
    Mentioned
    206 Post(s)
    Tagged
    4 Thread(s)
    you can now use api 21 - 28, but using api 26 is good for google
    Regards,


    Fernando Vivolo

    ... new things are coming ...

  7. #37
    Clicker Fusion 2.5 DeveloperAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleSWF Export Module
    Simflare's Avatar
    Join Date
    Oct 2013
    Location
    Australia
    Posts
    374
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Ok thanks. And do you know if people with newer phones can download apps even if the app doesn't support the latest API? I'm assuming so. Like if I only support API 8 and someone has API 27, can they still download it?

  8. #38
    Clickteam Clickteam
    Fernando's Avatar
    Join Date
    Dec 2006
    Posts
    6,318
    Mentioned
    206 Post(s)
    Tagged
    4 Thread(s)
    all, application are backward compatible, so a application made with build api 21 runs on device with newer apies
    Regards,


    Fernando Vivolo

    ... new things are coming ...

  9. #39
    Clicker Fusion 2.5 DeveloperAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleSWF Export Module
    Simflare's Avatar
    Join Date
    Oct 2013
    Location
    Australia
    Posts
    374
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Awesome, thanks @Fernando !

  10. #40
    Clicker Fusion 2.5Android Export ModuleHTML5 Export ModuleSWF Export Module
    xDeeringx's Avatar
    Join Date
    Dec 2013
    Posts
    27
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I have followed every instruction on this thread to be able to export to android... and I'm still getting this:

    Buildfile: C:\Users\scdee\AppData\Local\Temp\And4CA8.tmp\buil d.xml

    -set-mode-check:

    -set-debug-files:

    -check-env:
    [checkenv] Android SDK Tools Revision 25.2.5
    [checkenv] Installed at C:\Program Files (x86)\Android\android-sdk

    -setup:
    [echo] Project Name: RuntimeAndroid
    [gettype] Project Type: Application

    -set-debug-mode:

    -debug-obfuscation-check:

    -pre-build:

    -build-setup:
    [getbuildtools] Using latest Build Tools: 28.0.2
    [echo] Resolving Build Target for RuntimeAndroid...
    [gettarget] Project Target: Android 8.0.0
    [gettarget] API level: 26
    [echo] ----------
    [echo] Creating output directories if needed...
    [mkdir] Created dir: C:\Users\scdee\AppData\Local\Temp\And4CA8.tmp\bin
    [mkdir] Created dir: C:\Users\scdee\AppData\Local\Temp\And4CA8.tmp\bin\ res
    [mkdir] Created dir: C:\Users\scdee\AppData\Local\Temp\And4CA8.tmp\bin\ rsObj
    [mkdir] Created dir: C:\Users\scdee\AppData\Local\Temp\And4CA8.tmp\bin\ rsLibs
    [mkdir] Created dir: C:\Users\scdee\AppData\Local\Temp\And4CA8.tmp\gen
    [mkdir] Created dir: C:\Users\scdee\AppData\Local\Temp\And4CA8.tmp\bin\ classes
    [mkdir] Created dir: C:\Users\scdee\AppData\Local\Temp\And4CA8.tmp\bin\ dexedLibs
    [echo] ----------
    [echo] Resolving Dependencies for RuntimeAndroid...
    [dependency] Library dependencies:
    [dependency] No Libraries
    [dependency]
    [dependency] ------------------
    [echo] ----------
    [echo] Building Libraries with 'debug'...
    [subant] No sub-builds to iterate on

    -code-gen:
    [mergemanifest] Merging AndroidManifest files into one.
    [mergemanifest] Manifest merger disabled. Using project manifest only.
    [echo] Handling aidl files...
    [aidl] No AIDL files to compile.
    [echo] ----------
    [echo] Handling RenderScript files...
    [echo] ----------
    [echo] Handling Resources...
    [aapt] Generating resource IDs...
    [echo] ----------
    [echo] Handling BuildConfig class...
    [buildconfig] Generating BuildConfig class.

    -pre-compile:

    -compile:
    [javac] Compiling 380 source files to C:\Users\scdee\AppData\Local\Temp\And4CA8.tmp\bin\ classes
    [javac] warning: [options] source value 1.5 is obsolete and will be removed in a future release
    [javac] warning: [options] target value 1.5 is obsolete and will be removed in a future release
    [javac] warning: [options] To suppress warnings about obsolete options, use -Xlint:-options.
    [javac] C:\Users\scdee\AppData\Local\Temp\And4CA8.tmp\src\ Extensions\CRunInputType.java:544: error: cannot find symbol
    [javac] if(ViewExt instanceof CRunkcedit) {
    [javac] ^
    [javac] symbol: class CRunkcedit
    [javac] location: class CRunInputType
    [javac] C:\Users\scdee\AppData\Local\Temp\And4CA8.tmp\src\ Extensions\CRunInputType.java:545: error: cannot find symbol
    [javac] CRunkcedit edit = ((CRunkcedit)ViewExt);
    [javac] ^
    [javac] symbol: class CRunkcedit
    [javac] location: class CRunInputType
    [javac] C:\Users\scdee\AppData\Local\Temp\And4CA8.tmp\src\ Extensions\CRunInputType.java:545: error: cannot find symbol
    [javac] CRunkcedit edit = ((CRunkcedit)ViewExt);
    [javac] ^
    [javac] symbol: class CRunkcedit
    [javac] location: class CRunInputType
    [javac] C:\Users\scdee\AppData\Local\Temp\And4CA8.tmp\src\ Extensions\CRunInputType.java:577: error: cannot find symbol
    [javac] if(ViewExt instanceof CRunkcedit) {
    [javac] ^
    [javac] symbol: class CRunkcedit
    [javac] location: class CRunInputType
    [javac] C:\Users\scdee\AppData\Local\Temp\And4CA8.tmp\src\ Extensions\CRunInputType.java:578: error: cannot find symbol
    [javac] CRunkcedit edit = ((CRunkcedit)ViewExt);
    [javac] ^
    [javac] symbol: class CRunkcedit
    [javac] location: class CRunInputType
    [javac] C:\Users\scdee\AppData\Local\Temp\And4CA8.tmp\src\ Extensions\CRunInputType.java:578: error: cannot find symbol
    [javac] CRunkcedit edit = ((CRunkcedit)ViewExt);
    [javac] ^
    [javac] symbol: class CRunkcedit
    [javac] location: class CRunInputType
    [javac] C:\Users\scdee\AppData\Local\Temp\And4CA8.tmp\src\ Extensions\CRunInputType.java:881: error: cannot find symbol
    [javac] if(ViewExt instanceof CRunkcedit) {
    [javac] ^
    [javac] symbol: class CRunkcedit
    [javac] location: class CRunInputType
    [javac] C:\Users\scdee\AppData\Local\Temp\And4CA8.tmp\src\ Extensions\CRunInputType.java:882: error: cannot find symbol
    [javac] CRunkcedit edit = ((CRunkcedit)ViewExt);
    [javac] ^
    [javac] symbol: class CRunkcedit
    [javac] location: class CRunInputType
    [javac] C:\Users\scdee\AppData\Local\Temp\And4CA8.tmp\src\ Extensions\CRunInputType.java:882: error: cannot find symbol
    [javac] CRunkcedit edit = ((CRunkcedit)ViewExt);
    [javac] ^
    [javac] symbol: class CRunkcedit
    [javac] location: class CRunInputType
    [javac] C:\Users\scdee\AppData\Local\Temp\And4CA8.tmp\src\ Extensions\CRunInputType.java:902: error: cannot find symbol
    [javac] if(ViewExt instanceof CRunkcedit) {
    [javac] ^
    [javac] symbol: class CRunkcedit
    [javac] location: class CRunInputType
    [javac] C:\Users\scdee\AppData\Local\Temp\And4CA8.tmp\src\ Extensions\CRunInputType.java:903: error: cannot find symbol
    [javac] CRunkcedit edit = ((CRunkcedit)ViewExt);
    [javac] ^
    [javac] symbol: class CRunkcedit
    [javac] location: class CRunInputType
    [javac] C:\Users\scdee\AppData\Local\Temp\And4CA8.tmp\src\ Extensions\CRunInputType.java:903: error: cannot find symbol
    [javac] CRunkcedit edit = ((CRunkcedit)ViewExt);
    [javac] ^
    [javac] symbol: class CRunkcedit
    [javac] location: class CRunInputType
    [javac] C:\Users\scdee\AppData\Local\Temp\And4CA8.tmp\src\ Extensions\CRunInputType.java:922: error: cannot find symbol
    [javac] if(ViewExt instanceof CRunkcedit) {
    [javac] ^
    [javac] symbol: class CRunkcedit
    [javac] location: class CRunInputType
    [javac] C:\Users\scdee\AppData\Local\Temp\And4CA8.tmp\src\ Extensions\CRunInputType.java:923: error: cannot find symbol
    [javac] CRunkcedit edit = ((CRunkcedit)ViewExt);
    [javac] ^
    [javac] symbol: class CRunkcedit
    [javac] location: class CRunInputType
    [javac] C:\Users\scdee\AppData\Local\Temp\And4CA8.tmp\src\ Extensions\CRunInputType.java:923: error: cannot find symbol
    [javac] CRunkcedit edit = ((CRunkcedit)ViewExt);
    [javac] ^
    [javac] symbol: class CRunkcedit
    [javac] location: class CRunInputType
    [javac] C:\Users\scdee\AppData\Local\Temp\And4CA8.tmp\src\ Extensions\CRunInputType.java:941: error: cannot find symbol
    [javac] if(ViewExt instanceof CRunkcedit) {
    [javac] ^
    [javac] symbol: class CRunkcedit
    [javac] location: class CRunInputType
    [javac] C:\Users\scdee\AppData\Local\Temp\And4CA8.tmp\src\ Extensions\CRunInputType.java:942: error: cannot find symbol
    [javac] CRunkcedit edit = ((CRunkcedit)ViewExt);
    [javac] ^
    [javac] symbol: class CRunkcedit
    [javac] location: class CRunInputType
    [javac] C:\Users\scdee\AppData\Local\Temp\And4CA8.tmp\src\ Extensions\CRunInputType.java:942: error: cannot find symbol
    [javac] CRunkcedit edit = ((CRunkcedit)ViewExt);
    [javac] ^
    [javac] symbol: class CRunkcedit
    [javac] location: class CRunInputType
    [javac] Note: Some input files use or override a deprecated API.
    [javac] Note: Recompile with -Xlint:deprecation for details.
    [javac] Note: Some input files use unchecked or unsafe operations.
    [javac] Note: Recompile with -Xlint:unchecked for details.
    [javac] 18 errors
    [javac] 3 warnings

    BUILD FAILED
    C:\Program Files (x86)\Android\android-sdk\tools\ant\build.xml:716: The following error occurred while executing this line:
    C:\Program Files (x86)\Android\android-sdk\tools\ant\build.xml:730: Compile failed; see the compiler error output for details.

    Total time: 9 seconds
    any input and help would be awesome

Page 4 of 5 FirstFirst ... 2 3 4 5 LastLast

Similar Threads

  1. Replies: 56
    Last Post: 26th December 2017, 09:53 PM
  2. Can Fusion and Android Export Module create Android Live Wallpapers?
    By chickenlump in forum Android Export Module 2.5
    Replies: 5
    Last Post: 4th September 2015, 10:29 PM
  3. Setting up the Android SDK for the Android Export Module
    By Jeff in forum Android Export Module Version 2.0
    Replies: 3
    Last Post: 2nd October 2013, 05:08 PM
  4. Setting up the Android SDK for the Android Export Module
    By Jeff in forum Android Export Module 2.5
    Replies: 3
    Last Post: 2nd October 2013, 05:08 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •