User Tag List

Results 1 to 8 of 8

Thread: Facebook Obj Error - Help

  1. #1
    Clicker Multimedia Fusion 2 DeveloperAndroid Export Module
    johnnydias's Avatar
    Join Date
    Apr 2013
    Location
    São Paulo Brazil
    Posts
    64
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    Facebook Obj Error - Help

    Hello, I am trying to compile the sample FacebookX_V3 and I'm not getting.
    My SDK API 22 has to installed.
    Already tried putting the target for android 4.1 and 5.1 but they returned me the same error.
    Below the error log:

    Buildfile: C:\Users\Dias\AppData\Local\Temp\AndFD70.tmp\build .xml

    -set-mode-check:

    -set-debug-files:

    -check-env:
    [checkenv] Android SDK Tools Revision 24.4.1
    [checkenv] Installed at C:\Users\Dias\Desktop\adt-bundle-windows-x86-20140321\sdk

    -setup:
    [echo] Project Name: RuntimeAndroid
    [gettype] Project Type: Application

    -set-debug-mode:

    -debug-obfuscation-check:

    -pre-build:

    -build-setup:
    [getbuildtools] Using latest Build Tools: 23.0.1
    [echo] Resolving Build Target for RuntimeAndroid...
    [gettarget] Project Target: Android 5.1.1
    [gettarget] API level: 22
    [echo] ----------
    [echo] Creating output directories if needed...
    [mkdir] Created dir: C:\Users\Dias\AppData\Local\Temp\AndFD70.tmp\bin
    [mkdir] Created dir: C:\Users\Dias\AppData\Local\Temp\AndFD70.tmp\bin\r es
    [mkdir] Created dir: C:\Users\Dias\AppData\Local\Temp\AndFD70.tmp\bin\r sObj
    [mkdir] Created dir: C:\Users\Dias\AppData\Local\Temp\AndFD70.tmp\bin\r sLibs
    [mkdir] Created dir: C:\Users\Dias\AppData\Local\Temp\AndFD70.tmp\gen
    [mkdir] Created dir: C:\Users\Dias\AppData\Local\Temp\AndFD70.tmp\bin\c lasses
    [mkdir] Created dir: C:\Users\Dias\AppData\Local\Temp\AndFD70.tmp\bin\d exedLibs
    [echo] ----------
    [echo] Resolving Dependencies for RuntimeAndroid...
    [dependency] Library dependencies:
    [dependency]
    [dependency] ------------------
    [dependency] Ordered libraries:
    [dependency]
    [dependency] ------------------
    [echo] ----------
    [echo] Building Libraries with 'debug'...

    nodeps:

    -set-mode-check:

    -set-debug-files:

    -check-env:
    [checkenv] Android SDK Tools Revision 24.4.1
    [checkenv] Installed at C:\Users\Dias\Desktop\adt-bundle-windows-x86-20140321\sdk

    -setup:
    [echo] Project Name: facebook
    [gettype] Project Type: Android Library

    -set-debug-mode:

    -debug-obfuscation-check:

    -pre-build:

    -build-setup:
    [getbuildtools] Using latest Build Tools: 23.0.1
    [echo] Resolving Build Target for facebook...
    [gettarget] Project Target: Android 5.0.1
    [gettarget] API level: 21
    [echo] ----------
    [echo] Creating output directories if needed...
    [mkdir] Created dir: C:\Users\Dias\AppData\Local\Temp\AndFD70.tmp\faceb ook\bin
    [mkdir] Created dir: C:\Users\Dias\AppData\Local\Temp\AndFD70.tmp\faceb ook\bin\res
    [mkdir] Created dir: C:\Users\Dias\AppData\Local\Temp\AndFD70.tmp\faceb ook\bin\rsObj
    [mkdir] Created dir: C:\Users\Dias\AppData\Local\Temp\AndFD70.tmp\faceb ook\bin\rsLibs
    [mkdir] Created dir: C:\Users\Dias\AppData\Local\Temp\AndFD70.tmp\faceb ook\gen
    [mkdir] Created dir: C:\Users\Dias\AppData\Local\Temp\AndFD70.tmp\faceb ook\bin\classes
    [mkdir] Created dir: C:\Users\Dias\AppData\Local\Temp\AndFD70.tmp\faceb ook\bin\dexedLibs
    [echo] ----------
    [echo] Resolving Dependencies for facebook...
    [dependency] Library dependencies:
    [dependency] No Libraries
    [dependency]
    [dependency] ------------------

    -code-gen:
    [mergemanifest] Merging AndroidManifest files into one.
    [mergemanifest] Manifest merger disabled. Using project manifest only.
    [echo] Handling aidl files...
    [aidl] No AIDL files to compile.
    [echo] ----------
    [echo] Handling RenderScript files...
    [echo] ----------
    [echo] Handling Resources...
    [aapt] Generating resource IDs...
    [echo] ----------
    [echo] Handling BuildConfig class...
    [buildconfig] Generating BuildConfig class.

    -pre-compile:

    -compile:
    [javac] Compiling 155 source files to C:\Users\Dias\AppData\Local\Temp\AndFD70.tmp\faceb ook\bin\classes
    [javac] javac: invalid target release: 1.7
    [javac] Usage: javac <options> <source files>
    [javac] use -help for a list of possible options

    BUILD FAILED
    C:\Users\Dias\Desktop\adt-bundle-windows-x86-20140321\sdk\tools\ant\build.xml:597: The following error occurred while executing this line:
    C:\Users\Dias\Desktop\adt-bundle-windows-x86-20140321\sdk\tools\ant\build.xml:716: The following error occurred while executing this line:
    C:\Users\Dias\Desktop\adt-bundle-windows-x86-20140321\sdk\tools\ant\build.xml:730: Compile failed; see the compiler error output for details.

    Total time: 1 second

  2. #2
    Clickteam Clickteam
    Fernando's Avatar
    Join Date
    Dec 2006
    Posts
    6,650
    Mentioned
    280 Post(s)
    Tagged
    4 Thread(s)
    What java sdk do you have installed?.
    Regards,


    Fernando Vivolo

    ... new things are coming ...

  3. #3
    Clicker Multimedia Fusion 2 DeveloperAndroid Export Module
    johnnydias's Avatar
    Join Date
    Apr 2013
    Location
    São Paulo Brazil
    Posts
    64
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Android SDK Manager
    Revision 24.4.1
    ADD on XML Schema 7
    Repository XML Schema 11

  4. #4
    Clickteam Clickteam
    Fernando's Avatar
    Join Date
    Dec 2006
    Posts
    6,650
    Mentioned
    280 Post(s)
    Tagged
    4 Thread(s)
    check if you have installed api 21, it is required by facebook object
    Regards,


    Fernando Vivolo

    ... new things are coming ...

  5. #5
    Clicker Multimedia Fusion 2 DeveloperAndroid Export Module
    johnnydias's Avatar
    Join Date
    Apr 2013
    Location
    São Paulo Brazil
    Posts
    64
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Yes, it's installed, it installed up to 22.

  6. #6
    Clickteam Clickteam
    Fernando's Avatar
    Join Date
    Dec 2006
    Posts
    6,650
    Mentioned
    280 Post(s)
    Tagged
    4 Thread(s)
    and what java sdk please you have installed in your PC, also refer to this link that maybe will help you https://dl.dropboxusercontent.com/u/...stallation.pdf
    Regards,


    Fernando Vivolo

    ... new things are coming ...

  7. #7
    Clicker Multimedia Fusion 2 DeveloperAndroid Export Module
    johnnydias's Avatar
    Join Date
    Apr 2013
    Location
    São Paulo Brazil
    Posts
    64
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Java 1.6.0 And the error persists

  8. #8
    Clickteam Clickteam
    Fernando's Avatar
    Join Date
    Dec 2006
    Posts
    6,650
    Mentioned
    280 Post(s)
    Tagged
    4 Thread(s)
    oh sir, java sdk 1.6 is too old to build from api 20 to above please update to 1.7 that will solve your problem

    javac] Compiling 155 source files to C:\Users\Dias\AppData\Local\Temp\AndFD70.tmp\faceb ook\bin\classes
    [javac] javac: invalid target release: 1.7
    [javac] Usage: javac <options> <source files>
    [javac] use -help for a list of possible options
    Regards,


    Fernando Vivolo

    ... new things are coming ...

Similar Threads

  1. Replies: 10
    Last Post: 3rd October 2015, 03:59 PM
  2. Replies: 11
    Last Post: 15th March 2014, 05:22 AM
  3. [MARKETING] Pay Facebook Ad on Facebook mobile app
    By paobrasil in forum iOS Export Module Version 2.0
    Replies: 2
    Last Post: 30th March 2013, 04:32 PM
  4. Error with mmf1-game: extension load error in mmf2
    By Quinto in forum Multimedia Fusion 2 - Technical Support
    Replies: 3
    Last Post: 27th November 2006, 11:54 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •