User Tag List

Results 1 to 4 of 4

Thread: Build Error: Found 2 versions of google-play-services.jar

  1. #1
    Clicker Fusion 2.5 DeveloperAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleXNA Export Module

    Join Date
    Nov 2010
    Posts
    59
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Build Error: Found 2 versions of google-play-services.jar

    I am getting the following error when trying to build my game after adding Google Play Game Services. Anyone know what I am doing wrong here or what I need to do.


    [dependency] Ordered libraries:
    [dependency]
    [dependency] ------------------
    [dependency] Found 2 versions of google-play-services.jar in the dependency list,
    [dependency] but not all the versions are identical (check is based on SHA-1 only at this time).
    [dependency] All versions of the libraries must be the same at this time.
    [dependency] Versions found are:
    [dependency] Path: C:\Users\Slyon Studios\AppData\Local\Temp\And81A3.tmp\google-play-services_lib\libs\google-play-services.jar
    [dependency] Length: 3508206
    [dependency] SHA-1: 9b73d9aba531aa7ff5dd30e0c972e8ca550b362a
    [dependency] Path: C:\Users\SLYONS~1\AppData\Local\Temp\And81A3.tmp\l ibs\google-play-services.jar
    [dependency] Length: 3406972
    [dependency] SHA-1: 0f701f6802ba1a1f1fa7ac26d4db0666a89d15a6

    BUILD FAILED
    C:\Program Files (x86)\Android\android-sdk\tools\ant\build.xml:573: Jar mismatch! Fix your dependencies

  2. #2
    Clickteam Clickteam
    Fernando's Avatar
    Join Date
    Dec 2006
    Posts
    6,801
    Mentioned
    298 Post(s)
    Tagged
    4 Thread(s)
    You need version 285.1 to use google play games objects
    Regards,


    Fernando Vivolo

    ... new things are coming ...

  3. #3
    Clicker Fusion 2.5 DeveloperAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleXNA Export Module

    Join Date
    Nov 2010
    Posts
    59
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    After updating. It seems I am getting some facebook error. Not sure what that is about because I don't have anything facebook related in the game.

    -check-env:
    [checkenv] Android SDK Tools Revision 24.4.1
    [checkenv] Installed at C:\Program Files (x86)\Android\android-sdk

    -setup:
    [echo] Project Name: facebook
    [gettype] Project Type: Android Library

    -build-setup:
    [getbuildtools] Using latest Build Tools: 23.0.2
    [echo] Resolving Build Target for facebook...

    BUILD FAILED
    C:\Program Files (x86)\Android\android-sdk\tools\ant\build.xml:597: The following error occurred while executing this line:
    C:\Program Files (x86)\Android\android-sdk\tools\ant\build.xml:538: Unable to resolve project target 'android-10'

  4. #4
    Clickteam Clickteam
    Fernando's Avatar
    Join Date
    Dec 2006
    Posts
    6,801
    Mentioned
    298 Post(s)
    Tagged
    4 Thread(s)
    Unable to resolve project target 'android-10'

    you need to install api 10 which is used for Google Play Services.
    Regards,


    Fernando Vivolo

    ... new things are coming ...

Similar Threads

  1. Build Failed after installing Google Play Game Services objects
    By mutantdude in forum Android Export Module 2.5
    Replies: 4
    Last Post: 15th January 2016, 10:20 AM
  2. Google Play Game Objects error message
    By Marcone in forum Extension Development
    Replies: 0
    Last Post: 11th January 2016, 02:11 PM
  3. Android build error - file not found
    By larckson in forum Android Export Module 2.5
    Replies: 10
    Last Post: 22nd August 2015, 03:30 AM
  4. ANR error at Google Play
    By Alejandro in forum Android Export Module 2.5
    Replies: 5
    Last Post: 13th January 2015, 07:52 PM
  5. Error message on Google Play
    By Keli in forum Android Export Module 2.5
    Replies: 1
    Last Post: 20th November 2014, 06:55 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •