User Tag List

Results 1 to 4 of 4

Thread: AndroidPlus preferences saving issue

  1. #1
    Clicker Fusion 2.5 DeveloperAndroid Export ModuleHTML5 Export Module

    Join Date
    Feb 2016
    Posts
    6
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    AndroidPlus preferences saving issue

    Hi,

    I'm trying to save some data using the AndroidPlus object and I'm running into an issue where it doesn't seem to be saving/loading the right values. Events that are supposed to execute are not executing, as if the value has already been changed when it hasn't.

    I also have a few questions about the object - understanding these may fix my problem:
    - If i'm loading values on app startup, but the corresponding value has not yet been saved, will a default be assigned? what is it for each of the data types?
    - if there are no defaults assigned, is it possible to somehow skip loading values if they have not yet been saved?
    - Where is the preference file located on the android device?
    - What is the difference between using the AndroidPlus save preferences events and the INI object?


    I've tried looking around the forums, documentation, and example files but wasn't able to find the answers.
    Any and all help is greatly appreciated!

  2. #2
    Clickteam Clickteam
    Fernando's Avatar
    Join Date
    Dec 2006
    Posts
    6,369
    Mentioned
    219 Post(s)
    Tagged
    4 Thread(s)
    There is an example on how to use preferences in help ..... examples ...... androidplus

    Values does not exist if they are not saved and returning empty string or 0 and preferences all them are saved inside the data area of the application, so does not need permission
    Regards,


    Fernando Vivolo

    ... new things are coming ...

  3. #3
    Clicker Fusion 2.5 DeveloperAndroid Export ModuleHTML5 Export Module

    Join Date
    Feb 2016
    Posts
    6
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Having it saved in the data area is handy.

    I did a quick test though and it seems like it's returning -1 as a default value for integers, so that's what was causing my events to not fire. Is this intended or am I doing something wrong and it should be 0?

    Thanks!

  4. #4
    Clickteam Clickteam
    Fernando's Avatar
    Join Date
    Dec 2006
    Posts
    6,369
    Mentioned
    219 Post(s)
    Tagged
    4 Thread(s)
    yes this is intent, actually I updating this object please stay tune for next beta for testing this.

    thanks in advance
    Regards,


    Fernando Vivolo

    ... new things are coming ...

Similar Threads

  1. Android Saving Ini issue
    By Podunk in forum Android Export Module 2.5
    Replies: 3
    Last Post: 9th November 2016, 02:55 PM
  2. Questions about the AndroidPlus object and Share
    By Outcast in forum Android Export Module 2.5
    Replies: 23
    Last Post: 9th November 2015, 07:09 PM
  3. .Ini saving issue with Mac
    By pkthunda in forum Fusion 2.5
    Replies: 2
    Last Post: 27th May 2015, 05:07 PM
  4. 2.5 Skin Tutorial (Preferences)
    By darkmanx_429 in forum Fusion 2.5
    Replies: 2
    Last Post: 1st May 2014, 12:53 PM
  5. Saving Arrays, crash issue
    By pdsoft in forum Android Export Module Version 2.0
    Replies: 4
    Last Post: 15th July 2013, 10:46 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •