User Tag List

Page 1 of 2 1 2 LastLast
Results 1 to 10 of 16

Thread: Android export fails with error message

  1. #1
    Clicker Fusion 2.5Android Export Module

    Join Date
    Apr 2016
    Posts
    7
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Android export fails with error message

    Please help. I'm new to Clickteam Fusion. I get error message when I export using android / OUYA exporter. I have jdk and sdk installed. Paths in the fusion 2.5 preferences are set correctly. Using API 22 target version 5.1. Fusion won't export game. Here's the error log. Can someone tell me what I'm doing wrong. Any help would be appreciated.

    Buildfile: C:\Users\UNKLE-ME\AppData\Local\Temp\AndA887.tmp\build.xml

    -set-mode-check:

    -set-debug-files:

    -check-env:
    [checkenv] Android SDK Tools Revision 25.1.1
    [checkenv] Installed at C:\Users\UNKLE-ME\AppData\Local\Android\sdk

    -setup:
    [echo] Project Name: RuntimeAndroid
    [gettype] Project Type: Application

    -set-debug-mode:

    -debug-obfuscation-check:

    -pre-build:

    -build-setup:
    [getbuildtools] Using latest Build Tools: 24.0.0 rc3
    [echo] Resolving Build Target for RuntimeAndroid...
    [gettarget] Project Target: Android 5.1.1
    [gettarget] API level: 22
    [echo] ----------
    [echo] Creating output directories if needed...
    [mkdir] Created dir: C:\Users\UNKLE-ME\AppData\Local\Temp\AndA887.tmp\bin
    [mkdir] Created dir: C:\Users\UNKLE-ME\AppData\Local\Temp\AndA887.tmp\bin\res
    [mkdir] Created dir: C:\Users\UNKLE-ME\AppData\Local\Temp\AndA887.tmp\bin\rsObj
    [mkdir] Created dir: C:\Users\UNKLE-ME\AppData\Local\Temp\AndA887.tmp\bin\rsLibs
    [mkdir] Created dir: C:\Users\UNKLE-ME\AppData\Local\Temp\AndA887.tmp\gen
    [mkdir] Created dir: C:\Users\UNKLE-ME\AppData\Local\Temp\AndA887.tmp\bin\classes
    [mkdir] Created dir: C:\Users\UNKLE-ME\AppData\Local\Temp\AndA887.tmp\bin\dexedLibs
    [echo] ----------
    [echo] Resolving Dependencies for RuntimeAndroid...
    [dependency] Library dependencies:
    [dependency] No Libraries
    [dependency]
    [dependency] ------------------
    [echo] ----------
    [echo] Building Libraries with 'debug'...
    [subant] No sub-builds to iterate on

    -code-gen:
    [mergemanifest] Merging AndroidManifest files into one.
    [mergemanifest] Manifest merger disabled. Using project manifest only.
    [echo] Handling aidl files...
    [aidl] No AIDL files to compile.
    [echo] ----------
    [echo] Handling RenderScript files...
    [echo] ----------
    [echo] Handling Resources...
    [aapt] Generating resource IDs...
    [echo] ----------
    [echo] Handling BuildConfig class...
    [buildconfig] Generating BuildConfig class.

    -pre-compile:

    -compile:
    [javac] Compiling 338 source files to C:\Users\UNKLE-ME\AppData\Local\Temp\AndA887.tmp\bin\classes
    [javac] Note: Some input files use or override a deprecated API.
    [javac] Note: Recompile with -Xlint:deprecation for details.
    [javac] Note: Some input files use unchecked or unsafe operations.
    [javac] Note: Recompile with -Xlint:unchecked for details.

    -post-compile:

    -obfuscate:

    -dex:
    [dex] input: C:\Users\UNKLE-ME\AppData\Local\Temp\AndA887.tmp\bin\classes
    [dex] input: C:\Users\UNKLE-ME\AppData\Local\Temp\AndA887.tmp\libs\ouya-sdk.jar
    [dex] input: C:\Users\UNKLE-ME\AppData\Local\Temp\AndA887.tmp\libs\notificatio n.jar
    [dex] input: C:\Users\UNKLE-ME\AppData\Local\Temp\AndA887.tmp\libs\google-play-services.jar
    [dex] input: C:\Users\UNKLE-ME\AppData\Local\Temp\AndA887.tmp\libs\android-support-v4.jar
    [dex] input: C:\Users\UNKLE-ME\AppData\Local\Temp\AndA887.tmp\libs\gamecontrol ler.jar
    [dex] Pre-Dexing C:\Users\UNKLE-ME\AppData\Local\Temp\AndA887.tmp\libs\ouya-sdk.jar -> ouya-sdk-b3edee44135968bb26a3e870241457b6.jar
    [dx] java.lang.UnsupportedClassVersionError: com/android/dx/command/Main : Unsupported major.minor version 52.0
    [dx] at java.lang.ClassLoader.defineClass1(Native Method)
    [dx] at java.lang.ClassLoader.defineClass(ClassLoader.java :800)
    [dx] at java.security.SecureClassLoader.defineClass(Secure ClassLoader.java:142)
    [dx] at java.net.URLClassLoader.defineClass(URLClassLoader .java:449)
    [dx] at java.net.URLClassLoader.access$100(URLClassLoader. java:71)
    [dx] at java.net.URLClassLoader$1.run(URLClassLoader.java: 361)
    [dx] at java.net.URLClassLoader$1.run(URLClassLoader.java: 355)
    [dx] at java.security.AccessController.doPrivileged(Native Method)
    [dx] at java.net.URLClassLoader.findClass(URLClassLoader.j ava:354)
    [dx] at java.lang.ClassLoader.loadClass(ClassLoader.java:4 25)
    [dx] at java.lang.ClassLoader.loadClass(ClassLoader.java:4 12)
    [dx] at sun.misc.Launcher$AppClassLoader.loadClass(Launche r.java:308)
    [dx] at java.lang.ClassLoader.loadClass(ClassLoader.java:3 58)
    [dx] at sun.launcher.LauncherHelper.checkAndLoadMain(Launc herHelper.java:482)
    [dx] Exception in thread "main"

    BUILD FAILED
    C:\Users\UNKLE-ME\AppData\Local\Android\sdk\tools\ant\build.xml:8 88: The following error occurred while executing this line:
    C:\Users\UNKLE-ME\AppData\Local\Android\sdk\tools\ant\build.xml:8 90: The following error occurred while executing this line:
    C:\Users\UNKLE-ME\AppData\Local\Android\sdk\tools\ant\build.xml:9 02: The following error occurred while executing this line:
    C:\Users\UNKLE-ME\AppData\Local\Android\sdk\tools\ant\build.xml:2 83: null returned: 1

    Total time: 4 seconds

  2. #2
    Clickteam Clickteam
    Fernando's Avatar
    Join Date
    Dec 2006
    Posts
    6,654
    Mentioned
    281 Post(s)
    Tagged
    4 Thread(s)
    first time I see this message,

    what version of java sdk you are using?
    Regards,


    Fernando Vivolo

    ... new things are coming ...

  3. #3
    Clicker Fusion 2.5Android Export Module

    Join Date
    Apr 2016
    Posts
    7
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Fernando thanks for reply. I have java se development kit 7u79 32 bit. I have a 64 bit windows 7 machine. I read on another thread that only the 32 bit version of java sdk will work.

  4. #4
    Clickteam Clickteam
    Fernando's Avatar
    Join Date
    Dec 2006
    Posts
    6,654
    Mentioned
    281 Post(s)
    Tagged
    4 Thread(s)
    is your java sdk correctly set inside fusion? are all path set?
    Regards,


    Fernando Vivolo

    ... new things are coming ...

  5. #5
    Clicker Fusion 2.5Android Export Module

    Join Date
    Apr 2016
    Posts
    7
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Yes my paths are correct in fusion: C:\Program Files (x86)\Java\jdk1.7.0_79 --- android sdk is here: C:\Users\UNKLE-ME\AppData\Local\Android\sdk Should I put the android sdk in a different location? Thanks.

  6. #6
    Clickteam Clickteam
    Fernando's Avatar
    Join Date
    Dec 2006
    Posts
    6,654
    Mentioned
    281 Post(s)
    Tagged
    4 Thread(s)
    I always prefer to put in c:\ ... to avoid permission problems, but it should work

    and what version of Fusion you are using, can you register your license in passport I s always better for us to know how to answer question, which sometimes depend on version.
    Regards,


    Fernando Vivolo

    ... new things are coming ...

  7. #7
    Clickteam Clickteam
    Jeff's Avatar
    Join Date
    Jun 2006
    Location
    Battle Ground Washington
    Posts
    11,824
    Mentioned
    8 Post(s)
    Tagged
    2 Thread(s)
    Does this same error happen when you try to export out a blank app or is it confined to this one app?

  8. #8
    Clicker Fusion 2.5Android Export Module

    Join Date
    Apr 2016
    Posts
    7
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I have Fusion 2.5 standard (Build R284.10). This error happens even with a blank app. I never used passport.

  9. #9
    Clickteam Clickteam
    Fernando's Avatar
    Join Date
    Dec 2006
    Posts
    6,654
    Mentioned
    281 Post(s)
    Tagged
    4 Thread(s)
    please update to the latest beta 285.2, you are mixing versions
    Regards,


    Fernando Vivolo

    ... new things are coming ...

  10. #10
    Clicker Fusion 2.5Android Export Module

    Join Date
    Apr 2016
    Posts
    7
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I upgraded to fusion 2.5 beta build 285.2 and I still get the same error message. Should I get an older version of Java jdk? Thanks.

Page 1 of 2 1 2 LastLast

Similar Threads

  1. Android Export Error - Build Fails Every Time Between 4-5 sec
    By henryhissagames in forum Android Export Module 2.5
    Replies: 4
    Last Post: 29th December 2015, 06:27 PM
  2. Build process fails with error message 'cannot build blah.mfa
    By Jusfury in forum Android Export Module 2.5
    Replies: 7
    Last Post: 22nd May 2015, 08:16 PM
  3. Build process fails with error message 'Invalid keystore format'
    By Anton in forum Android Export Module 2.5
    Replies: 7
    Last Post: 4th February 2015, 11:58 PM
  4. Build fails no error message - Old Device
    By DaveC in forum Android Export Module 2.5
    Replies: 3
    Last Post: 19th August 2014, 02:53 AM
  5. android build and run freezes Fusion 2.5 (no error message)
    By brett in forum Android Export Module 2.5
    Replies: 4
    Last Post: 15th March 2014, 07:45 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •