User Tag List

Results 1 to 6 of 6

Thread: Game stops for a second after playing sample 1st time

  1. #1
    Clicker Fusion 2.5

    Join Date
    Jun 2016
    Posts
    3
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Game stops for a second after playing sample 1st time

    Hi everyone,

    I'm starting to learn Fusion, and I encounter something strange. The first time a sample is played my game pauses for a second and then continues. It happens every time, only after playing the sample for the first time... Any idea how I can fix this??

    I uploaded my test project...

    Thanks in advance!
    Attached files Attached files

  2. #2
    Clickteam Clickteam
    Jeff's Avatar
    Join Date
    Jun 2006
    Location
    Battle Ground Washington
    Posts
    11,822
    Mentioned
    7 Post(s)
    Tagged
    2 Thread(s)
    I am running the beta version 286.3 and don't seem to notice the issue.

    What I noticed in the past was on some computers the initialization of the sound engine was sometimes slow.
    To counter that I would play a sample at start of frame to get it going.
    This could be a tiny soundless sound file or just your games background soundtrack.

    Other things that might help it is recompiling your file into the OGG format -- Lighter weight then a WAV and better then an MP3 -- but if you notice the delay the first time it plays I would do the initialization trick above.

    Also I notice if you have 2 green blocks your actually playing the sound file twice so it sounds twice as loud and a little fuzzy.
    I might have some events to counter this but I still would allow the explosions to play over each other if green boxes where hit at different collision events.
    (IE different bullets colliding)

  3. #3
    Clicker Fusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleUniversal Windows Platform Export ModuleSWF Export Module
    aenever's Avatar
    Join Date
    Jun 2013
    Posts
    1,436
    Mentioned
    14 Post(s)
    Tagged
    0 Thread(s)
    I don't seem to see the problem in your file however, I've had games where this has happened in the past (seems to happen mostly if I use the bouncing ball) it's like the application takes a bit to kick in. As it only happens at the beginning of the application, one way around this is to have a pseudo loading screen. If the loading screen stutters for a bit, it looks quite normal and then on with the game

    Or update to the latest beta to see if it fixes the problem.

  4. #4
    Clicker Fusion 2.5

    Join Date
    Jun 2016
    Posts
    3
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks for all the suggestions so far, I did some more experimentations last night and I think the problem is not specifically related to Fusion. I build the same test with Construct 2, and I encountered the same problem. Everything runs fine, until the first time the sample plays. Going to experiment today more with different source samples... I keep you up to date on this...

  5. #5
    Clicker Fusion 2.5

    Join Date
    Jun 2016
    Posts
    3
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Ok, the problem was indeed the .wav file I used! I converted it to OGG and the little delay is gone

  6. #6
    Clicker Fusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleUniversal Windows Platform Export ModuleSWF Export Module
    aenever's Avatar
    Join Date
    Jun 2013
    Posts
    1,436
    Mentioned
    14 Post(s)
    Tagged
    0 Thread(s)
    That's great news thanks for the share

Similar Threads

  1. Looping sample stops between 10-20% of frame changes in iOS
    By ITZ_A_TARP in forum iOS Export Module 2.5
    Replies: 12
    Last Post: 13th May 2016, 10:38 PM
  2. Sample (MOD file) stops when frame restarts
    By teddyq in forum Multimedia Fusion 2 - Technical Support
    Replies: 9
    Last Post: 22nd October 2014, 05:43 AM
  3. Replies: 7
    Last Post: 26th April 2014, 12:56 PM
  4. Does not know when sample is not playing
    By OldManClayton in forum SWF/Flash Export Module Version 2.0
    Replies: 7
    Last Post: 19th March 2010, 08:49 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •