User Tag List

Results 1 to 3 of 3

Thread: Error when compiling the apk

  1. #1
    Clicker Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)

    Join Date
    Oct 2010
    Posts
    11
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Exclamation Error when compiling the apk

    Hello !

    I've finally finished my game !
    However, when it comes to compiling the game into an apk, I keep getting the same error. Here's the error code :

    Code:
    Buildfile: C:\Users\JEBAIS~1\AppData\Local\Temp\And5483.tmp\build.xml
    
    -set-mode-check:
    
    -set-debug-files:
    
    -check-env:
     [checkenv] Android SDK Tools Revision 25.1.7
     [checkenv] Installed at P:\Android\sdk
    
    -setup:
         [echo] Project Name: RuntimeAndroid
      [gettype] Project Type: Application
    
    -set-debug-mode:
    
    -debug-obfuscation-check:
    
    -pre-build:
    
    -build-setup:
    [getbuildtools] Using latest Build Tools: 24.0.1
         [echo] Resolving Build Target for RuntimeAndroid...
    [gettarget] Project Target:   Android 4.3.1
    [gettarget] API level:        18
         [echo] ----------
         [echo] Creating output directories if needed...
        [mkdir] Created dir: C:\Users\JEBAIS~1\AppData\Local\Temp\And5483.tmp\bin
        [mkdir] Created dir: C:\Users\JEBAIS~1\AppData\Local\Temp\And5483.tmp\bin\res
        [mkdir] Created dir: C:\Users\JEBAIS~1\AppData\Local\Temp\And5483.tmp\bin\rsObj
        [mkdir] Created dir: C:\Users\JEBAIS~1\AppData\Local\Temp\And5483.tmp\bin\rsLibs
        [mkdir] Created dir: C:\Users\JEBAIS~1\AppData\Local\Temp\And5483.tmp\gen
        [mkdir] Created dir: C:\Users\JEBAIS~1\AppData\Local\Temp\And5483.tmp\bin\classes
        [mkdir] Created dir: C:\Users\JEBAIS~1\AppData\Local\Temp\And5483.tmp\bin\dexedLibs
         [echo] ----------
         [echo] Resolving Dependencies for RuntimeAndroid...
    [dependency] Library dependencies:
    [dependency] No Libraries
    [dependency] 
    [dependency] ------------------
         [echo] ----------
         [echo] Building Libraries with 'debug'...
       [subant] No sub-builds to iterate on
    
    -code-gen:
    [mergemanifest] Merging AndroidManifest files into one.
    [mergemanifest] Manifest merger disabled. Using project manifest only.
         [echo] Handling aidl files...
         [aidl] No AIDL files to compile.
         [echo] ----------
         [echo] Handling RenderScript files...
         [echo] ----------
         [echo] Handling Resources...
         [aapt] Generating resource IDs...
         [echo] ----------
         [echo] Handling BuildConfig class...
    [buildconfig] Generating BuildConfig class.
    
    -pre-compile:
    
    -compile:
        [javac] Compiling 374 source files to C:\Users\JEBAIS~1\AppData\Local\Temp\And5483.tmp\bin\classes
        [javac] Note: Some input files use or override a deprecated API.
        [javac] Note: Recompile with -Xlint:deprecation for details.
        [javac] Note: Some input files use unchecked or unsafe operations.
        [javac] Note: Recompile with -Xlint:unchecked for details.
    
    -post-compile:
    
    -obfuscate:
    
    -dex:
          [dex] input: C:\Users\JEBAIS~1\AppData\Local\Temp\And5483.tmp\bin\classes
          [dex] input: C:\Users\JEBAIS~1\AppData\Local\Temp\And5483.tmp\libs\library.jar
          [dex] input: C:\Users\JEBAIS~1\AppData\Local\Temp\And5483.tmp\libs\android-support-v4.jar
          [dex] input: C:\Users\JEBAIS~1\AppData\Local\Temp\And5483.tmp\libs\zip_file.jar
          [dex] input: C:\Users\JEBAIS~1\AppData\Local\Temp\And5483.tmp\libs\zbar.jar
          [dex] input: C:\Users\JEBAIS~1\AppData\Local\Temp\And5483.tmp\libs\downloader_library.jar
          [dex] Pre-Dexing C:\Users\JEBAIS~1\AppData\Local\Temp\And5483.tmp\libs\library.jar -> library-d8412b9103f89338bfdfb2c77e0cbc89.jar
           [dx] java.lang.UnsupportedClassVersionError: com/android/dx/command/Main : Unsupported major.minor version 52.0
           [dx] 	at java.lang.ClassLoader.defineClass1(Native Method)
           [dx] 	at java.lang.ClassLoader.defineClass(ClassLoader.java:800)
           [dx] 	at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142)
           [dx] 	at java.net.URLClassLoader.defineClass(URLClassLoader.java:449)
           [dx] 	at java.net.URLClassLoader.access$100(URLClassLoader.java:71)
           [dx] 	at java.net.URLClassLoader$1.run(URLClassLoader.java:361)
           [dx] 	at java.net.URLClassLoader$1.run(URLClassLoader.java:355)
           [dx] 	at java.security.AccessController.doPrivileged(Native Method)
           [dx] 	at java.net.URLClassLoader.findClass(URLClassLoader.java:354)
           [dx] 	at java.lang.ClassLoader.loadClass(ClassLoader.java:425)
           [dx] 	at java.lang.ClassLoader.loadClass(ClassLoader.java:412)
           [dx] 	at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:308)
           [dx] 	at java.lang.ClassLoader.loadClass(ClassLoader.java:358)
           [dx] 	at sun.launcher.LauncherHelper.checkAndLoadMain(LauncherHelper.java:482)
           [dx] Exception in thread "main" 
    
    BUILD FAILED
    P:\Android\sdk\tools\ant\build.xml:888: The following error occurred while executing this line:
    P:\Android\sdk\tools\ant\build.xml:890: The following error occurred while executing this line:
    P:\Android\sdk\tools\ant\build.xml:902: The following error occurred while executing this line:
    P:\Android\sdk\tools\ant\build.xml:283: null returned: 1
    
    Total time: 2 seconds
    I've got the latest Java JDK 7 on 32 bits (x86), and the latest Android SDK, with every files described it this video : https://www.youtube.com/watch?v=5yH2Vmdtmes
    (Android 4.3.1 with API 18)

    Do you know what we could do ?


    Thanks !

  2. #2
    Clicker

    Fusion 2.5 MacFusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export ModuleiOS Export ModuleInstall Creator Pro
    Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)
    wpd's Avatar
    Join Date
    Nov 2015
    Location
    SE Asia
    Posts
    405
    Mentioned
    12 Post(s)
    Tagged
    1 Thread(s)
    well probably too old, you could go with
    latest java 8, latest android sdk 24, latest fusion build

  3. #3
    Clickteam Clickteam
    Jeff's Avatar
    Join Date
    Jun 2006
    Location
    Battle Ground Washington
    Posts
    11,825
    Mentioned
    8 Post(s)
    Tagged
    2 Thread(s)
    Are you able to compile a blank app APK?
    This would help us to know if your having problems in one app or if we need to look at all the items you installed and make sure they are set up correctly.

    Also what is your apps package name?

Similar Threads

  1. error LLVM 5.1 when compiling
    By Wolkam in forum iOS Export Module 2.5
    Replies: 3
    Last Post: 25th June 2014, 09:19 AM
  2. error compiling...
    By Ahiru in forum iOS Export Module Version 2.0
    Replies: 9
    Last Post: 22nd January 2013, 08:10 PM
  3. Compiling error when changing 'Build filename'
    By Yos in forum iOS Export Module Version 2.0
    Replies: 3
    Last Post: 10th April 2012, 01:55 PM
  4. Beta 22 - Compiling Error
    By Kisguri in forum Android Export Module Version 2.0
    Replies: 3
    Last Post: 13th March 2012, 05:05 PM
  5. Beta 4/SDK 4.1: Error compiling the application
    By Koji_Kabuto in forum iOS Export Module Version 2.0
    Replies: 2
    Last Post: 30th October 2010, 10:41 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •