User Tag List

Results 1 to 4 of 4

Thread: Can't seem to build apk. :(

  1. #1
    Clicker Fusion 2.5Android Export ModuleiOS Export ModuleSWF Export Module
    leightonw87's Avatar
    Join Date
    Jan 2012
    Posts
    85
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Unhappy Can't seem to build apk. :(

    Hi guy, having issue today with building and not sure what's going on here.

    Below is the Build error log:

    Code:
    Buildfile: C:\Users\LEIGHT~1.LEI\AppData\Local\Temp\AndFAB8.tmp\build.xml
    
    -set-mode-check:
    
    -set-debug-files:
    
    -check-env:
     [checkenv] Android SDK Tools Revision 25.1.7
     [checkenv] Installed at C:\Users\leighton.leighton-PC\AppData\Local\Android\sdk
    
    -setup:
         [echo] Project Name: RuntimeAndroid
      [gettype] Project Type: Application
    
    -set-debug-mode:
    
    -debug-obfuscation-check:
    
    -pre-build:
    
    -build-setup:
    [getbuildtools] Using latest Build Tools: 23.0.3
         [echo] Resolving Build Target for RuntimeAndroid...
    [gettarget] Project Target:   Android 7.0
    [gettarget] API level:        24
         [echo] ----------
         [echo] Creating output directories if needed...
        [mkdir] Created dir: C:\Users\LEIGHT~1.LEI\AppData\Local\Temp\AndFAB8.tmp\bin
        [mkdir] Created dir: C:\Users\LEIGHT~1.LEI\AppData\Local\Temp\AndFAB8.tmp\bin\res
        [mkdir] Created dir: C:\Users\LEIGHT~1.LEI\AppData\Local\Temp\AndFAB8.tmp\bin\rsObj
        [mkdir] Created dir: C:\Users\LEIGHT~1.LEI\AppData\Local\Temp\AndFAB8.tmp\bin\rsLibs
        [mkdir] Created dir: C:\Users\LEIGHT~1.LEI\AppData\Local\Temp\AndFAB8.tmp\gen
        [mkdir] Created dir: C:\Users\LEIGHT~1.LEI\AppData\Local\Temp\AndFAB8.tmp\bin\classes
        [mkdir] Created dir: C:\Users\LEIGHT~1.LEI\AppData\Local\Temp\AndFAB8.tmp\bin\dexedLibs
         [echo] ----------
         [echo] Resolving Dependencies for RuntimeAndroid...
    [dependency] Library dependencies:
    [dependency] No Libraries
    [dependency] 
    [dependency] ------------------
         [echo] ----------
         [echo] Building Libraries with 'debug'...
       [subant] No sub-builds to iterate on
    
    -code-gen:
    [mergemanifest] Merging AndroidManifest files into one.
    [mergemanifest] Manifest merger disabled. Using project manifest only.
         [echo] Handling aidl files...
         [aidl] No AIDL files to compile.
         [echo] ----------
         [echo] Handling RenderScript files...
         [echo] ----------
         [echo] Handling Resources...
         [aapt] Generating resource IDs...
         [echo] ----------
         [echo] Handling BuildConfig class...
    [buildconfig] Generating BuildConfig class.
    
    -pre-compile:
    
    -compile:
        [javac] Compiling 395 source files to C:\Users\LEIGHT~1.LEI\AppData\Local\Temp\AndFAB8.tmp\bin\classes
        [javac] warning: C:\Users\leighton.leighton-PC\AppData\Local\Android\sdk\platforms\android-24\android.jar(java/lang/Object.class): major version 52 is newer than 51, the highest major version supported by this compiler.
        [javac]   It is recommended that the compiler be upgraded.
        [javac] warning: C:\Users\leighton.leighton-PC\AppData\Local\Android\sdk\platforms\android-24\android.jar(java/util/ArrayList.class): major version 52 is newer than 51, the highest major version supported by this compiler.
        [javac]   It is recommended that the compiler be upgraded.
        [javac] warning: C:\Users\leighton.leighton-PC\AppData\Local\Android\sdk\platforms\android-24\android.jar(java/util/Arrays.class): major version 52 is newer than 51, the highest major version supported by this compiler.
        [javac]   It is recommended that the compiler be upgraded.
        [javac] warning: C:\Users\leighton.leighton-PC\AppData\Local\Android\sdk\platforms\android-24\android.jar(java/util/HashMap.class): major version 52 is newer than 51, the highest major version supported by this compiler.
        [javac]   It is recommended that the compiler be upgraded.
        [javac] warning: C:\Users\leighton.leighton-PC\AppData\Local\Android\sdk\platforms\android-24\android.jar(java/util/Map.class): major version 52 is newer than 51, the highest major version supported by this compiler.
        [javac]   It is recommended that the compiler be upgraded.
        [javac] warning: C:\Users\leighton.leighton-PC\AppData\Local\Android\sdk\platforms\android-24\android.jar(java/util/Random.class): major version 52 is newer than 51, the highest major version supported by this compiler.
        [javac]   It is recommended that the compiler be upgraded.
        [javac] warning: C:\Users\leighton.leighton-PC\AppData\Local\Android\sdk\platforms\android-24\android.jar(javax/microedition/khronos/egl/EGL10.class): major version 52 is newer than 51, the highest major version supported by this compiler.
        [javac]   It is recommended that the compiler be upgraded.
        [javac] warning: C:\Users\leighton.leighton-PC\AppData\Local\Android\sdk\platforms\android-24\android.jar(javax/microedition/khronos/egl/EGL11.class): major version 52 is newer than 51, the highest major version supported by this compiler.
        [javac]   It is recommended that the compiler be upgraded.
        [javac] warning: C:\Users\leighton.leighton-PC\AppData\Local\Android\sdk\platforms\android-24\android.jar(java/io/File.class): major version 52 is newer than 51, the highest major version supported by this compiler.
        [javac]   It is recommended that the compiler be upgraded.
        [javac] warning: C:\Users\leighton.leighton-PC\AppData\Local\Android\sdk\platforms\android-24\android.jar(java/io/FileInputStream.class): major version 52 is newer than 51, the highest major version supported by this compiler.
        [javac]   It is recommended that the compiler be upgraded.
        [javac] warning: C:\Users\leighton.leighton-PC\AppData\Local\Android\sdk\platforms\android-24\android.jar(java/io/IOException.class): major version 52 is newer than 51, the highest major version supported by this compiler.
        [javac]   It is recommended that the compiler be upgraded.
        [javac] warning: C:\Users\leighton.leighton-PC\AppData\Local\Android\sdk\platforms\android-24\android.jar(java/io/InputStream.class): major version 52 is newer than 51, the highest major version supported by this compiler.
        [javac]   It is recommended that the compiler be upgraded.
        [javac] warning: C:\Users\leighton.leighton-PC\AppData\Local\Android\sdk\platforms\android-24\android.jar(java/net/HttpURLConnection.class): major version 52 is newer than 51, the highest major version supported by this compiler.
        [javac]   It is recommended that the compiler be upgraded.
        [javac] warning: C:\Users\leighton.leighton-PC\AppData\Local\Android\sdk\platforms\android-24\android.jar(java/net/URL.class): major version 52 is newer than 51, the highest major version supported by this compiler.
        [javac]   It is recommended that the compiler be upgraded.
        [javac] warning: C:\Users\leighton.leighton-PC\AppData\Local\Android\sdk\platforms\android-24\android.jar(java/util/HashSet.class): major version 52 is newer than 51, the highest major version supported by this compiler.
        [javac]   It is recommended that the compiler be upgraded.
        [javac] warning: C:\Users\leighton.leighton-PC\AppData\Local\Android\sdk\platforms\android-24\android.jar(java/util/Iterator.class): major version 52 is newer than 51, the highest major version supported by this compiler.
        [javac]   It is recommended that the compiler be upgraded.
        [javac] warning: C:\Users\leighton.leighton-PC\AppData\Local\Android\sdk\platforms\android-24\android.jar(java/util/Set.class): major version 52 is newer than 51, the highest major version supported by this compiler.
        [javac]   It is recommended that the compiler be upgraded.
        [javac] warning: C:\Users\leighton.leighton-PC\AppData\Local\Android\sdk\platforms\android-24\android.jar(android/content/Context.class): major version 52 is newer than 51, the highest major version supported by this compiler.
        [javac]   It is recommended that the compiler be upgraded.
        [javac] warning: C:\Users\leighton.leighton-PC\AppData\Local\Android\sdk\platforms\android-24\android.jar(android/os/AsyncTask.class): major version 52 is newer than 51, the highest major version supported by this compiler.
        [javac]   It is recommended that the compiler be upgraded.
        [javac] warning: C:\Users\leighton.leighton-PC\AppData\Local\Android\sdk\platforms\android-24\android.jar(android/text/ClipboardManager.class): major version 52 is newer than 51, the highest major version supported by this compiler.
        [javac]   It is recommended that the compiler be upgraded.
        [javac] warning: C:\Users\leighton.leighton-PC\AppData\Local\Android\sdk\platforms\android-24\android.jar(android/view/KeyEvent.class): major version 52 is newer than 51, the highest major version supported by this compiler.
        [javac]   It is recommended that the compiler be upgraded.
        [javac] warning: C:\Users\leighton.leighton-PC\AppData\Local\Android\sdk\platforms\android-24\android.jar(android/view/MenuItem.class): major version 52 is newer than 51, the highest major version supported by this compiler.
        [javac]   It is recommended that the compiler be upgraded.
        [javac] warning: C:\Users\leighton.leighton-PC\AppData\Local\Android\sdk\platforms\android-24\android.jar(android/view/View.class): major version 52 is newer than 51, the highest major version supported by this compiler.
        [javac]   It is recommended that the compiler be upgraded.
        [javac] warning: C:\Users\leighton.leighton-PC\AppData\Local\Android\sdk\platforms\android-24\android.jar(android/view/ViewGroup.class): major version 52 is newer than 51, the highest major version supported by this compiler.
        [javac]   It is recommended that the compiler be upgraded.
        [javac] warning: C:\Users\leighton.leighton-PC\AppData\Local\Android\sdk\platforms\android-24\android.jar(android/view/ViewGroup$LayoutParams.class): major version 52 is newer than 51, the highest major version supported by this compiler.
        [javac]   It is recommended that the compiler be upgraded.
        [javac] warning: C:\Users\leighton.leighton-PC\AppData\Local\Android\sdk\platforms\android-24\android.jar(android/graphics/Rect.class): major version 52 is newer than 51, the highest major version supported by this compiler.
        [javac]   It is recommended that the compiler be upgraded.
        [javac] warning: C:\Users\leighton.leighton-PC\AppData\Local\Android\sdk\platforms\android-24\android.jar(java/lang/String.class): major version 52 is newer than 51, the highest major version supported by this compiler.
        [javac]   It is recommended that the compiler be upgraded.
        [javac] warning: C:\Users\leighton.leighton-PC\AppData\Local\Android\sdk\platforms\android-24\android.jar(java/util/List.class): major version 52 is newer than 51, the highest major version supported by this compiler.
        [javac]   It is recommended that the compiler be upgraded.
        [javac] warning: C:\Users\leighton.leighton-PC\AppData\Local\Android\sdk\platforms\android-24\android.jar(android/content/Intent.class): major version 52 is newer than 51, the highest major version supported by this compiler.
        [javac]   It is recommended that the compiler be upgraded.
        [javac] warning: C:\Users\leighton.leighton-PC\AppData\Local\Android\sdk\platforms\android-24\android.jar(android/view/Menu.class): major version 52 is newer than 51, the highest major version supported by this compiler.
        [javac]   It is recommended that the compiler be upgraded.
        [javac] warning: C:\Users\leighton.leighton-PC\AppData\Local\Android\sdk\platforms\android-24\android.jar(java/lang/Boolean.class): major version 52 is newer than 51, the highest major version supported by this compiler.
        [javac]   It is recommended that the compiler be upgraded.
        [javac] warning: C:\Users\leighton.leighton-PC\AppData\Local\Android\sdk\platforms\android-24\android.jar(java/util/Collection.class): major version 52 is newer than 51, the highest major version supported by this compiler.
        [javac]   It is recommended that the compiler be upgraded.
        [javac] warning: C:\Users\leighton.leighton-PC\AppData\Local\Android\sdk\platforms\android-24\android.jar(java/lang/Iterable.class): major version 52 is newer than 51, the highest major version supported by this compiler.
        [javac]   It is recommended that the compiler be upgraded.
        [javac] warning: C:\Users\leighton.leighton-PC\AppData\Local\Android\sdk\platforms\android-24\android.jar(java/util/RandomAccess.class): major version 52 is newer than 51, the highest major version supported by this compiler.
        [javac]   It is recommended that the compiler be upgraded.
        [javac] warning: C:\Users\leighton.leighton-PC\AppData\Local\Android\sdk\platforms\android-24\android.jar(java/lang/Cloneable.class): major version 52 is newer than 51, the highest major version supported by this compiler.
        [javac]   It is recommended that the compiler be upgraded.
        [javac] warning: C:\Users\leighton.leighton-PC\AppData\Local\Android\sdk\platforms\android-24\android.jar(java/io/Serializable.class): major version 52 is newer than 51, the highest major version supported by this compiler.
        [javac]   It is recommended that the compiler be upgraded.
        [javac] warning: C:\Users\leighton.leighton-PC\AppData\Local\Android\sdk\platforms\android-24\android.jar(java/util/AbstractList.class): major version 52 is newer than 51, the highest major version supported by this compiler.
        [javac]   It is recommended that the compiler be upgraded.
        [javac] warning: C:\Users\leighton.leighton-PC\AppData\Local\Android\sdk\platforms\android-24\android.jar(java/util/AbstractCollection.class): major version 52 is newer than 51, the highest major version supported by this compiler.
        [javac]   It is recommended that the compiler be upgraded.
        [javac] warning: C:\Users\leighton.leighton-PC\AppData\Local\Android\sdk\platforms\android-24\android.jar(java/lang/Integer.class): major version 52 is newer than 51, the highest major version supported by this compiler.
        [javac]   It is recommended that the compiler be upgraded.
        [javac] warning: C:\Users\leighton.leighton-PC\AppData\Local\Android\sdk\platforms\android-24\android.jar(java/io/DataInputStream.class): major version 52 is newer than 51, the highest major version supported by this compiler.
        [javac]   It is recommended that the compiler be upgraded.
        [javac] warning: C:\Users\leighton.leighton-PC\AppData\Local\Android\sdk\platforms\android-24\android.jar(java/io/DataOutputStream.class): major version 52 is newer than 51, the highest major version supported by this compiler.
        [javac]   It is recommended that the compiler be upgraded.
        [javac] warning: C:\Users\leighton.leighton-PC\AppData\Local\Android\sdk\platforms\android-24\android.jar(android/graphics/Typeface.class): major version 52 is newer than 51, the highest major version supported by this compiler.
        [javac]   It is recommended that the compiler be upgraded.
        [javac] warning: C:\Users\leighton.leighton-PC\AppData\Local\Android\sdk\platforms\android-24\android.jar(java/io/FileNotFoundException.class): major version 52 is newer than 51, the highest major version supported by this compiler.
        [javac]   It is recommended that the compiler be upgraded.
        [javac] warning: C:\Users\leighton.leighton-PC\AppData\Local\Android\sdk\platforms\android-24\android.jar(java/io/FileOutputStream.class): major version 52 is newer than 51, the highest major version supported by this compiler.
        [javac]   It is recommended that the compiler be upgraded.
        [javac] warning: C:\Users\leighton.leighton-PC\AppData\Local\Android\sdk\platforms\android-24\android.jar(java/lang/reflect/InvocationTargetException.class): major version 52 is newer than 51, the highest major version supported by this compiler.
        [javac]   It is recommended that the compiler be upgraded.
        [javac] warning: C:\Users\leighton.leighton-PC\AppData\Local\Android\sdk\platforms\android-24\android.jar(java/lang/reflect/Method.class): major version 52 is newer than 51, the highest major version supported by this compiler.
        [javac]   It is recommended that the compiler be upgraded.
        [javac] warning: C:\Users\leighton.leighton-PC\AppData\Local\Android\sdk\platforms\android-24\android.jar(java/util/Locale.class): major version 52 is newer than 51, the highest major version supported by this compiler.
        [javac]   It is recommended that the compiler be upgraded.
        [javac] warning: C:\Users\leighton.leighton-PC\AppData\Local\Android\sdk\platforms\android-24\android.jar(android/Manifest.class): major version 52 is newer than 51, the highest major version supported by this compiler.
        [javac]   It is recommended that the compiler be upgraded.
        [javac] warning: C:\Users\leighton.leighton-PC\AppData\Local\Android\sdk\platforms\android-24\android.jar(android/accounts/Account.class): major version 52 is newer than 51, the highest major version supported by this compiler.
        [javac]   It is recommended that the compiler be upgraded.
        [javac] warning: C:\Users\leighton.leighton-PC\AppData\Local\Android\sdk\platforms\android-24\android.jar(android/accounts/AccountManager.class): major version 52 is newer than 51, the highest major version supported by this compiler.
        [javac]   It is recommended that the compiler be upgraded.
        [javac] warning: C:\Users\leighton.leighton-PC\AppData\Local\Android\sdk\platforms\android-24\android.jar(android/annotation/SuppressLint.class): major version 52 is newer than 51, the highest major version supported by this compiler.
        [javac]   It is recommended that the compiler be upgraded.
        [javac] warning: C:\Users\leighton.leighton-PC\AppData\Local\Android\sdk\platforms\android-24\android.jar(android/app/KeyguardManager.class): major version 52 is newer than 51, the highest major version supported by this compiler.
        [javac]   It is recommended that the compiler be upgraded.
        [javac] warning: C:\Users\leighton.leighton-PC\AppData\Local\Android\sdk\platforms\android-24\android.jar(android/bluetooth/BluetoothAdapter.class): major version 52 is newer than 51, the highest major version supported by this compiler.
        [javac]   It is recommended that the compiler be upgraded.
        [javac] warning: C:\Users\leighton.leighton-PC\AppData\Local\Android\sdk\platforms\android-24\android.jar(android/content/BroadcastReceiver.class): major version 52 is newer than 51, the highest major version supported by this compiler.
        [javac]   It is recommended that the compiler be upgraded.
        [javac] warning: C:\Users\leighton.leighton-PC\AppData\Local\Android\sdk\platforms\android-24\android.jar(android/content/IntentFilter.class): major version 52 is newer than 51, the highest major version supported by this compiler.
        [javac]   It is recommended that the compiler be upgraded.
        [javac] warning: C:\Users\leighton.leighton-PC\AppData\Local\Android\sdk\platforms\android-24\android.jar(android/content/pm/ActivityInfo.class): major version 52 is newer than 51, the highest major version supported by this compiler.
        [javac]   It is recommended that the compiler be upgraded.
        [javac] warning: C:\Users\leighton.leighton-PC\AppData\Local\Android\sdk\platforms\android-24\android.jar(android/content/pm/PackageManager.class): major version 52 is newer than 51, the highest major version supported by this compiler.
        [javac]   It is recommended that the compiler be upgraded.
        [javac] warning: C:\Users\leighton.leighton-PC\AppData\Local\Android\sdk\platforms\android-24\android.jar(android/graphics/Bitmap.class): major version 52 is newer than 51, the highest major version supported by this compiler.
        [javac]   It is recommended that the compiler be upgraded.
        [javac] warning: C:\Users\leighton.leighton-PC\AppData\Local\Android\sdk\platforms\android-24\android.jar(android/graphics/Canvas.class): major version 52 is newer than 51, the highest major version supported by this compiler.
        [javac]   It is recommended that the compiler be upgraded.
        [javac] warning: C:\Users\leighton.leighton-PC\AppData\Local\Android\sdk\platforms\android-24\android.jar(android/graphics/Matrix.class): major version 52 is newer than 51, the highest major version supported by this compiler.
        [javac]   It is recommended that the compiler be upgraded.
        [javac] warning: C:\Users\leighton.leighton-PC\AppData\Local\Android\sdk\platforms\android-24\android.jar(android/graphics/Paint.class): major version 52 is newer than 51, the highest major version supported by this compiler.
        [javac]   It is recommended that the compiler be upgraded.
        [javac] warning: C:\Users\leighton.leighton-PC\AppData\Local\Android\sdk\platforms\android-24\android.jar(android/net/ConnectivityManager.class): major version 52 is newer than 51, the highest major version supported by this compiler.
        [javac]   It is recommended that the compiler be upgraded.
        [javac] warning: C:\Users\leighton.leighton-PC\AppData\Local\Android\sdk\platforms\android-24\android.jar(android/net/NetworkInfo.class): major version 52 is newer than 51, the highest major version supported by this compiler.
        [javac]   It is recommended that the compiler be upgraded.
        [javac] warning: C:\Users\leighton.leighton-PC\AppData\Local\Android\sdk\platforms\android-24\android.jar(android/net/Uri.class): major version 52 is newer than 51, the highest major version supported by this compiler.
        [javac]   It is recommended that the compiler be upgraded.
        [javac] warning: C:\Users\leighton.leighton-PC\AppData\Local\Android\sdk\platforms\android-24\android.jar(android/os/BatteryManager.class): major version 52 is newer than 51, the highest major version supported by this compiler.
        [javac]   It is recommended that the compiler be upgraded.
        [javac] warning: C:\Users\leighton.leighton-PC\AppData\Local\Android\sdk\platforms\android-24\android.jar(android/os/Environment.class): major version 52 is newer than 51, the highest major version supported by this compiler.
        [javac]   It is recommended that the compiler be upgraded.
        [javac] warning: C:\Users\leighton.leighton-PC\AppData\Local\Android\sdk\platforms\android-24\android.jar(android/os/Vibrator.class): major version 52 is newer than 51, the highest major version supported by this compiler.
        [javac]   It is recommended that the compiler be upgraded.
        [javac] warning: C:\Users\leighton.leighton-PC\AppData\Local\Android\sdk\platforms\android-24\android.jar(android/telephony/TelephonyManager.class): major version 52 is newer than 51, the highest major version supported by this compiler.
        [javac]   It is recommended that the compiler be upgraded.
        [javac] warning: C:\Users\leighton.leighton-PC\AppData\Local\Android\sdk\platforms\android-24\android.jar(android/view/WindowManager.class): major version 52 is newer than 51, the highest major version supported by this compiler.
        [javac]   It is recommended that the compiler be upgraded.
        [javac] warning: C:\Users\leighton.leighton-PC\AppData\Local\Android\sdk\platforms\android-24\android.jar(android/app/Activity.class): major version 52 is newer than 51, the highest major version supported by this compiler.
        [javac]   It is recommended that the compiler be upgraded.
        [javac] warning: C:\Users\leighton.leighton-PC\AppData\Local\Android\sdk\platforms\android-24\android.jar(android/os/Bundle.class): major version 52 is newer than 51, the highest major version supported by this compiler.
        [javac]   It is recommended that the compiler be upgraded.
        [javac] warning: C:\Users\leighton.leighton-PC\AppData\Local\Android\sdk\platforms\android-24\android.jar(android/view/MotionEvent.class): major version 52 is newer than 51, the highest major version supported by this compiler.
        [javac]   It is recommended that the compiler be upgraded.
        [javac] warning: C:\Users\leighton.leighton-PC\AppData\Local\Android\sdk\platforms\android-24\android.jar(android/content/res/AssetFileDescriptor.class): major version 52 is newer than 51, the highest major version supported by this compiler.
        [javac]   It is recommended that the compiler be upgraded.
        [javac] warning: C:\Users\leighton.leighton-PC\AppData\Local\Android\sdk\platforms\android-24\android.jar(android/media/SoundPool.class): major version 52 is newer than 51, the highest major version supported by this compiler.
        [javac]   It is recommended that the compiler be upgraded.
        [javac] warning: C:\Users\leighton.leighton-PC\AppData\Local\Android\sdk\platforms\android-24\android.jar(android/os/SystemClock.class): major version 52 is newer than 51, the highest major version supported by this compiler.
        [javac]   It is recommended that the compiler be upgraded.
        [javac] warning: C:\Users\leighton.leighton-PC\AppData\Local\Android\sdk\platforms\android-24\android.jar(android/media/AudioManager.class): major version 52 is newer than 51, the highest major version supported by this compiler.
        [javac]   It is recommended that the compiler be upgraded.
        [javac] warning: C:\Users\leighton.leighton-PC\AppData\Local\Android\sdk\platforms\android-24\android.jar(android/media/AudioManager$OnAudioFocusChangeListener.class): major version 52 is newer than 51, the highest major version supported by this compiler.
        [javac]   It is recommended that the compiler be upgraded.
        [javac] warning: C:\Users\leighton.leighton-PC\AppData\Local\Android\sdk\platforms\android-24\android.jar(android/content/pm/PackageInfo.class): major version 52 is newer than 51, the highest major version supported by this compiler.
        [javac]   It is recommended that the compiler be upgraded.
        [javac] warning: C:\Users\leighton.leighton-PC\AppData\Local\Android\sdk\platforms\android-24\android.jar(android/util/DisplayMetrics.class): major version 52 is newer than 51, the highest major version supported by this compiler.
        [javac]   It is recommended that the compiler be upgraded.
        [javac] warning: C:\Users\leighton.leighton-PC\AppData\Local\Android\sdk\platforms\android-24\android.jar(android/hardware/Sensor.class): major version 52 is newer than 51, the highest major version supported by this compiler.
        [javac]   It is recommended that the compiler be upgraded.
        [javac] warning: C:\Users\leighton.leighton-PC\AppData\Local\Android\sdk\platforms\android-24\android.jar(android/hardware/SensorEvent.class): major version 52 is newer than 51, the highest major version supported by this compiler.
        [javac]   It is recommended that the compiler be upgraded.
        [javac] warning: C:\Users\leighton.leighton-PC\AppData\Local\Android\sdk\platforms\android-24\android.jar(android/hardware/SensorEventListener.class): major version 52 is newer than 51, the highest major version supported by this compiler.
        [javac]   It is recommended that the compiler be upgraded.
        [javac] warning: C:\Users\leighton.leighton-PC\AppData\Local\Android\sdk\platforms\android-24\android.jar(android/hardware/SensorManager.class): major version 52 is newer than 51, the highest major version supported by this compiler.
        [javac]   It is recommended that the compiler be upgraded.
        [javac] warning: C:\Users\leighton.leighton-PC\AppData\Local\Android\sdk\platforms\android-24\android.jar(android/graphics/Color.class): major version 52 is newer than 51, the highest major version supported by this compiler.
        [javac]   It is recommended that the compiler be upgraded.
        [javac] warning: C:\Users\leighton.leighton-PC\AppData\Local\Android\sdk\platforms\android-24\android.jar(android/view/ViewParent.class): major version 52 is newer than 51, the highest major version supported by this compiler.
        [javac]   It is recommended that the compiler be upgraded.
        [javac] warning: C:\Users\leighton.leighton-PC\AppData\Local\Android\sdk\platforms\android-24\android.jar(android/view/ViewManager.class): major version 52 is newer than 51, the highest major version supported by this compiler.
        [javac]   It is recommended that the compiler be upgraded.
        [javac] warning: C:\Users\leighton.leighton-PC\AppData\Local\Android\sdk\platforms\android-24\android.jar(android/graphics/drawable/Drawable.class): major version 52 is newer than 51, the highest major version supported by this compiler.
        [javac]   It is recommended that the compiler be upgraded.
        [javac] warning: C:\Users\leighton.leighton-PC\AppData\Local\Android\sdk\platforms\android-24\android.jar(android/graphics/drawable/Drawable$Callback.class): major version 52 is newer than 51, the highest major version supported by this compiler.
        [javac]   It is recommended that the compiler be upgraded.
        [javac] warning: C:\Users\leighton.leighton-PC\AppData\Local\Android\sdk\platforms\android-24\android.jar(android/view/KeyEvent$Callback.class): major version 52 is newer than 51, the highest major version supported by this compiler.
        [javac]   It is recommended that the compiler be upgraded.
        [javac] warning: C:\Users\leighton.leighton-PC\AppData\Local\Android\sdk\platforms\android-24\android.jar(android/os/Parcelable.class): major version 52 is newer than 51, the highest major version supported by this compiler.
        [javac]   It is recommended that the compiler be upgraded.
        [javac] warning: C:\Users\leighton.leighton-PC\AppData\Local\Android\sdk\platforms\android-24\android.jar(android/view/InputEvent.class): major version 52 is newer than 51, the highest major version supported by this compiler.
        [javac]   It is recommended that the compiler be upgraded.
        [javac] warning: C:\Users\leighton.leighton-PC\AppData\Local\Android\sdk\platforms\android-24\android.jar(android/view/accessibility/AccessibilityEventSource.class): major version 52 is newer than 51, the highest major version supported by this compiler.
        [javac]   It is recommended that the compiler be upgraded.
        [javac] warning: C:\Users\leighton.leighton-PC\AppData\Local\Android\sdk\platforms\android-24\android.jar(java/lang/Thread.class): major version 52 is newer than 51, the highest major version supported by this compiler.
        [javac]   It is recommended that the compiler be upgraded.
        [javac] warning: C:\Users\leighton.leighton-PC\AppData\Local\Android\sdk\platforms\android-24\android.jar(android/app/KeyguardManager$KeyguardLock.class): major version 52 is newer than 51, the highest major version supported by this compiler.
        [javac]   It is recommended that the compiler be upgraded.
        [javac] warning: C:\Users\leighton.leighton-PC\AppData\Local\Android\sdk\platforms\android-24\android.jar(android/view/WindowManager$LayoutParams.class): major version 52 is newer than 51, the highest major version supported by this compiler.
        [javac]   It is recommended that the compiler be upgraded.
        [javac] warning: C:\Users\leighton.leighton-PC\AppData\Local\Android\sdk\platforms\android-24\android.jar(java/io/BufferedInputStream.class): major version 52 is newer than 51, the highest major version supported by this compiler.
        [javac]   It is recommended that the compiler be upgraded.
        [javac] warning: C:\Users\leighton.leighton-PC\AppData\Local\Android\sdk\platforms\android-24\android.jar(android/graphics/BitmapFactory.class): major version 52 is newer than 51, the highest major version supported by this compiler.
        [javac]   It is recommended that the compiler be upgraded.
        [javac] warning: C:\Users\leighton.leighton-PC\AppData\Local\Android\sdk\platforms\android-24\android.jar(android/media/MediaPlayer.class): major version 52 is newer than 51, the highest major version supported by this compiler.
        [javac]   It is recommended that the compiler be upgraded.
        [javac] warning: C:\Users\leighton.leighton-PC\AppData\Local\Android\sdk\platforms\android-24\android.jar(android/media/MediaPlayer$OnErrorListener.class): major version 52 is newer than 51, the highest major version supported by this compiler.
        [javac]   It is recommended that the compiler be upgraded.
        [javac] warning: C:\Users\leighton.leighton-PC\AppData\Local\Android\sdk\platforms\android-24\android.jar(android/os/Build.class): major version 52 is newer than 51, the highest major version supported by this compiler.
        [javac]   It is recommended that the compiler be upgraded.
        [javac] C:\Users\LEIGHT~1.LEI\AppData\Local\Temp\AndFAB8.tmp\src\com\badlogic\gdx\utils\LongMap.java:679: error: name clash: remove() in MapIterator and remove() in Iterator have the same erasure, yet neither overrides the other
        [javac] 	static public class Entries<V> extends MapIterator<V> implements Iterable<Entry<V>>, Iterator<Entry<V>> {
        [javac] 	              ^
        [javac] C:\Users\LEIGHT~1.LEI\AppData\Local\Temp\AndFAB8.tmp\src\com\badlogic\gdx\utils\LongMap.java:712: error: name clash: remove() in MapIterator and remove() in Iterator have the same erasure, yet neither overrides the other
        [javac] 	static public class Values<V> extends MapIterator<V> implements Iterable<V>, Iterator<V> {
        [javac] 	              ^
        [javac] Note: Some input files use or override a deprecated API.
        [javac] Note: Recompile with -Xlint:deprecation for details.
        [javac] Note: Some input files use unchecked or unsafe operations.
        [javac] Note: Recompile with -Xlint:unchecked for details.
        [javac] 2 errors
        [javac] 100 warnings
    
    BUILD FAILED
    C:\Users\leighton.leighton-PC\AppData\Local\Android\sdk\tools\ant\build.xml:716: The following error occurred while executing this line:
    C:\Users\leighton.leighton-PC\AppData\Local\Android\sdk\tools\ant\build.xml:730: Compile failed; see the compiler error output for details.
    
    Total time: 33 seconds
    There's not much in the app other than a menu that slides in and a top actionbar I made.
    I'm only using the Easing Object and Array object in the app so far but nothing being done with the array yet.

  2. #2
    Clickteam Clickteam
    Fernando's Avatar
    Join Date
    Dec 2006
    Posts
    6,359
    Mentioned
    218 Post(s)
    Tagged
    4 Thread(s)
    this error is because you need to update to java sdk 8 to use api 24 and builds tool 24 or 25. please also use latest update 287.2
    Regards,


    Fernando Vivolo

    ... new things are coming ...

  3. #3
    Clicker Fusion 2.5Android Export ModuleiOS Export ModuleSWF Export Module
    leightonw87's Avatar
    Join Date
    Jan 2012
    Posts
    85
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I always update Fusion but sure I got Java 8...

    Code:
    C:\Users\leighton.leighton-PC>java -version
    java version "1.8.0_101"
    Java(TM) SE Runtime Environment (build 1.8.0_101-b13)
    Java HotSpot(TM) 64-Bit Server VM (build 25.101-b13, mixed mode)
    
    C:\Users\leighton.leighton-PC>"C:\Program Files\Java\jdk1.8.0_91\bin\javac.exe"
    -version
    javac 1.8.0_91

  4. #4
    Clicker Fusion 2.5Android Export ModuleiOS Export ModuleSWF Export Module
    leightonw87's Avatar
    Join Date
    Jan 2012
    Posts
    85
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Fixed it, it was using JDK 7 in preferences\General tab.

Similar Threads

  1. Getting build error when trying to build for Android
    By Outcast in forum Android Export Module 2.5
    Replies: 7
    Last Post: 19th March 2016, 07:10 PM
  2. Build process fails with error message 'cannot build blah.mfa
    By Jusfury in forum Android Export Module 2.5
    Replies: 7
    Last Post: 22nd May 2015, 09:16 PM
  3. ICP3 build 50 7.5GB build > 2.5GB installer which doesn't run?
    By aniceguy in forum Install Creator and Patch Maker
    Replies: 4
    Last Post: 28th March 2015, 12:07 PM
  4. Build.xmp
    By Lukiester in forum Android Export Module Version 2.0
    Replies: 2
    Last Post: 22nd June 2014, 02:23 AM
  5. I can't build or run :(
    By Fuuriokun in forum HTML5 Export Module 2.5
    Replies: 2
    Last Post: 21st August 2012, 08:41 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •