User Tag List

Results 1 to 8 of 8

Thread: Can't run .sln in visual studio

  1. #1
    Clicker Fusion 2.5 MaciOS Export ModuleInstall Creator Pro
    Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)

    Join Date
    Nov 2014
    Location
    USA
    Posts
    46
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Can't run .sln in visual studio

    Whenever I try to run my project in local machine,* I get this error ""10.0.10586.0" is not a supported value for TargetPlatformVersion. Please change it on the Project Property page."* How do I fix this?error2.jpg

  2. #2
    Clickteam Clickteam

    Join Date
    Jun 2006
    Location
    France
    Posts
    13,645
    Mentioned
    230 Post(s)
    Tagged
    3 Thread(s)
    This message is displayed when your target device is not up-to-date (check the version of Windows in the parameters of the target device - or your copy of Windows on your local machine if you aren't running on an external device). The latest version of Windows is 14393 iirc.

    If you can't update your version, 2 solutions:

    1. Right click the project name in VS, select "Properties" and change the target and min versions, for example to 10.0.10240.0

    2. If you use the build 287.3 (beta version), you can change these values in the UWP tab in the properties of the application (changing them in previous builds has no effect on the project settings).

  3. #3
    Clicker Fusion 2.5 DeveloperAndroid Export ModuleHTML5 Export ModuleSWF Export ModuleInstall Creator ProPatch Maker
    Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Fusion 2.5+ DLC (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)
    DJFuego's Avatar
    Join Date
    Jul 2006
    Location
    UK
    Posts
    1,414
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    I discovered I was using version 1 build of Visual studio 2015 (Personal edition) You should download Build Version 3 if you don't have this as it seemed to fix this issue for me when I had the same error.

  4. #4
    Clicker Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)
    Bree's Avatar
    Join Date
    May 2014
    Posts
    317
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)
    I'm having this issue as well. Right now I'm just trying to get it to work on my PC, by choosing Local Machine, but it doesn't work when I chose Device either (I have the SDK on the phone as well). Tried both with no luck, same error.

    I've tried everything Yves mentioned. I don't have the 287.3 beta clickteam, but I was able to change the target in the properties of visual studio with no problem. I got a new error message after that says 10.0.10240.0 is not supported. Tried just punching in plain 10.0.0.0 too. I have uninstalled and reinstalled visual studio twice.

    Errors:

    error : "10.0.10586.0" is not a supported value for TargetPlatformVersion.

    and

    Error "10.0.14393.0" is not a supported value for TargetPlatformVersion. Please change it on the Project Property page.

    and

    error : "10.0.10240.0" is not a supported value for TargetPlatformVersion


    If I hit system info I have Version 10.0.14393 Build 14393 (Tried changing to 10.0.14393.0 too, didn't work). Under Visual Studio it says I have Version 14.0.25431.01 Update 3. Anyone have anything else I might be able to try and check?

    Update: I've tried on 2 machines so far with the same error message.

  5. #5
    Clickteam Clickteam

    Join Date
    Jun 2006
    Location
    France
    Posts
    13,645
    Mentioned
    230 Post(s)
    Tagged
    3 Thread(s)
    In the installer of Visual Studio, did you check the SDKs in the Universal Windows App Development Tools section? To see this, open the Windows parameters, go to the application list, find MS VS 2015, click on it to modify it and check its installation options.

    vsopt.png

  6. #6
    Clicker Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)
    Bree's Avatar
    Join Date
    May 2014
    Posts
    317
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)
    Thanks Yves, that's actually what it was! Anybody else stuck on this make sure you do custom install, default doesn't seem to include it for Visual Studio. But I'm having another error now. When I ran it the first time it worked great. Then when I closed it there was a box behind my program that said something about scripting, I honestly didn't read it well enough and just hit OK or Yes.. . Well ever since I did that when I run my program now it keeps returning this error:

    Unhandled exception at line 508, column 25 in ms-appx://bf1ee2ca-eed9-8cb0-14e3-42ab339c65b3/js/runtime/extensions/source/KcArray.js?1476474215428

    0x800a13a5 - JavaScript runtime error: Array length must be a finite positive integer.

    It highlights this bit of code as the problem:
    newArray = new Array(dimz*dimY*dim;
    Is there a way to turn off whatever I turned on, or is there something else going on here? My array is 0 based, I hope that's not the problem.

  7. #7
    Clickteam Clickteam

    Join Date
    Jun 2006
    Location
    France
    Posts
    13,645
    Mentioned
    230 Post(s)
    Tagged
    3 Thread(s)
    >> My array is 0 based, I hope that's not the problem.

    It's the problem. We'll add a protection against this in the build 287.4. EDIT: it seems it's a bit more complicated, we'll fix it.

  8. #8
    Clicker Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)
    Bree's Avatar
    Join Date
    May 2014
    Posts
    317
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)
    Dang Thanks for the update!! I was worried it was something I did in visual studio because it seemed to work the first time - lol. I'll hang on for the fix then! It would be too much to change all the arrays at this point.

Similar Threads

  1. Visual Studio Version requirement
    By advaith in forum XNA Export Module 2.5
    Replies: 4
    Last Post: 10th December 2016, 09:25 AM
  2. Visual Studio 2015 Visual Studio 2015 Community
    By Perry in forum Universal Windows Platform Module 2.5
    Replies: 2
    Last Post: 12th August 2016, 08:02 PM
  3. Compiling in Visual Studio.. And then....?
    By Perry in forum Universal Windows Platform Module 2.5
    Replies: 2
    Last Post: 25th July 2016, 09:49 PM
  4. You Need Visual Studio for a PC Game Windows 10?
    By Merrie in forum Universal Windows Platform Module 2.5
    Replies: 1
    Last Post: 23rd July 2016, 01:26 AM
  5. visual studio 2005
    By jpcr in forum Extension Development
    Replies: 2
    Last Post: 11th February 2007, 12:41 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •