User Tag List

Page 1 of 2 1 2 LastLast
Results 1 to 10 of 15

Thread: Animation does not disappear when finished

  1. #1
    Clicker Fusion 2.5 Developer

    Join Date
    Aug 2016
    Location
    Utah, USA
    Posts
    79
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Animation does not disappear when finished

    Question,
    So I have gone back and forth in different things trying to get my animation to disappear when complete. I found a tutorial that showed you could use an alternate value and basically toggle the animation in stopped position on and off. I tried that but it didn't work. I have tried visibility, stop animation, destroy. Could someone tell me what the usual code is for turning on and off an animation. The ones I have made are different explosions. I am trying to also make them have different effects. This first one destroys the enemy for the length of the animation. The next one I would like to just stop or slow the enemy for the length of the animation. Any suggestions or if you could point me to a tutorial I'd really appreciate it. Thanks much, Cathy

  2. #2
    Clicker Fusion 2.5 DeveloperAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleSWF Export Module
    KLiK-iT's Avatar
    Join Date
    Sep 2011
    Location
    New Jersey
    Posts
    2,862
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Can you post a mfa? That would be the best way to go. We need to see what you are asking to do.

  3. #3
    Clicker Fusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleUniversal Windows Platform Export ModuleSWF Export Module
    aenever's Avatar
    Join Date
    Jun 2013
    Posts
    1,407
    Mentioned
    13 Post(s)
    Tagged
    0 Thread(s)
    1) You could force an animation to a blank animation frame when finished.
    2) You could leave the last animation frame blank and loop the animation so that it returns to the blank and continually loops.
    3) You could destroy the Active (animation) when finished or at the last frame.
    4) You could change the animation to another animation sequence of 2 frames with the first being blank (and the second containing anything small because it won't ever be seen), and set the animation speed to zero.
    5) You could make the Active invisible when the animation finishes or when it reaches the last frame (just be aware that the animation frames start counting from zero not one).
    6) Have the last animation frame blank & don't loop, it will stay on the last blank frame.

    All these ideas will work, it just depends what you prefer and what you game requires

    Here's an example: Animations disappear.mfa

  4. #4
    Clicker Fusion 2.5Fusion 2.5 Mac
    Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)
    zip2kx's Avatar
    Join Date
    Jun 2015
    Posts
    766
    Mentioned
    17 Post(s)
    Tagged
    0 Thread(s)
    It's hard to say without seeing it but

    A) check so you haven't put the animation on loop
    B) Unless you are using the built in animations like walking, lauching etc you have to manually trigger the changes with changing the animation to the different ones.
    C) Double check you don't have an event that constantly triggers the animation that dont want to change, e.g. an always or "If flag 0 is off" event.

  5. #5
    Clicker Fusion 2.5 Developer

    Join Date
    Aug 2016
    Location
    Utah, USA
    Posts
    79
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks for all the great suggestions!!! I'm going to try some of them this afternoon and see how it goes. You guys are awesome!

  6. #6
    Clicker Fusion 2.5 Developer

    Join Date
    Aug 2016
    Location
    Utah, USA
    Posts
    79
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Frustration. I can't figure this out. I have tried all these different suggestions. If I change one thing then the animation doesn't show at all or it stops and doesn't go away. So I wondered if it was something to do with the plasmabomb animation and tried it with the shockerbomb and I'm having the same issues. I'm thinking either I am missing some fundamental coding rules that I am not aware of that is causing me problems with this stuff and my physics engine or I have done something wrong in my game that is effecting many of my attempts at coding. Probably the former. Here is a link to my game. If someone could look at this and give me some advice I would greatly appreciate it. https://www.dropbox.com/s/phelloct7f...anima.mfa?dl=0

  7. #7
    Clicker Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)

    Join Date
    Sep 2016
    Posts
    12
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    In the newest beta release today it addresses this issue: ""- In low frame rate conditions some animations didn't reach the end."". Could this possibly be related?

  8. #8
    Clicker Fusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleUniversal Windows Platform Export ModuleSWF Export Module
    aenever's Avatar
    Join Date
    Jun 2013
    Posts
    1,407
    Mentioned
    13 Post(s)
    Tagged
    0 Thread(s)
    Cathy you need to add a create plasma bomb condition. At the moment the plasma bomb is being called to a position yet one doesn't exist on the screen. The animation is working fine. Just add create plasma bomb at 0 , 0. In line 43 at the top. In your case destroy after animation has finished will work better too (line 46) Cheers

  9. #9
    Clicker Fusion 2.5 Developer

    Join Date
    Aug 2016
    Location
    Utah, USA
    Posts
    79
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    aenever, I put the create condition in which did help some, but I had to click multiple times on button to make animation start- supposed to be single click. I have experimented with animation on loop- then it won't turn off, even with destroy on line 46. If I have the animation play once, it doesn't show up on screen. Runthis, I didn't see the beta release but I don't know how to fix my frame rate unless I made the animation really long and then increased the frame rate because I want it to stay on screen for about 4 seconds.

  10. #10
    Clicker Fusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleUniversal Windows Platform Export ModuleSWF Export Module
    aenever's Avatar
    Join Date
    Jun 2013
    Posts
    1,407
    Mentioned
    13 Post(s)
    Tagged
    0 Thread(s)
    You could loop the animation manually so that it only plays once yet stays on the screen for the required 4 seconds. As for the multiple clicks needed to trigger the animation that's a new problem you'll have to isolate. It wouldn't have anything to do with the animation itself, rather it's something to do with the way it's triggered.

Page 1 of 2 1 2 LastLast

Similar Threads

  1. Replies: 5
    Last Post: 9th June 2016, 10:37 AM
  2. Paste Into Background disappear?
    By mikecom in forum Fusion 2.5
    Replies: 1
    Last Post: 31st August 2014, 12:54 AM
  3. module installation disappear
    By CrystalNoir in forum Android Export Module Version 2.0
    Replies: 4
    Last Post: 12th March 2013, 08:13 AM
  4. iOS exporter disappear from the list
    By Fanotherpg in forum iOS Export Module Version 2.0
    Replies: 3
    Last Post: 20th April 2011, 01:30 PM
  5. Disappear animation not playing
    By mobichan in forum Multimedia Fusion 2 - Technical Support
    Replies: 5
    Last Post: 4th March 2009, 05:50 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •