User Tag List

Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13

Thread: Admob with new Google Ad compile error

  1. #1
    Forum Moderator

    Fusion 2.5 MacFusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleUniversal Windows Platform Export ModuleSWF Export ModuleMac Export ModuleInstall Creator Pro
    Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)
    Perry's Avatar
    Join Date
    Dec 2013
    Location
    Watertown, WI
    Posts
    4,334
    Mentioned
    49 Post(s)
    Tagged
    0 Thread(s)

    Admob with new Google Ad compile error

    Anyone having issues with compiling Admob with the latest Google Ads Frame work ? 7.15.0 ?

    I was working fine with an older version, but now I am getting tons of errors, and no clue what to do.

  2. #2
    Forum Moderator

    Fusion 2.5 MacFusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleUniversal Windows Platform Export ModuleSWF Export ModuleMac Export ModuleInstall Creator Pro
    Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)
    Perry's Avatar
    Join Date
    Dec 2013
    Location
    Watertown, WI
    Posts
    4,334
    Mentioned
    49 Post(s)
    Tagged
    0 Thread(s)
    ok issue resolved.

    IOS 10.x needs 3 more frameworks added to the project. VS IOS 9 and Xcode 7

    Learned something today

  3. #3
    Clicker

    Fusion 2.5 MacFusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export ModuleiOS Export ModuleInstall Creator Pro
    Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)
    wpd's Avatar
    Join Date
    Nov 2015
    Location
    SE Asia
    Posts
    406
    Mentioned
    12 Post(s)
    Tagged
    1 Thread(s)
    yeah, those additional frameworks gave me tons of headaches a month ago, must update the guides

    Not just that, apple rejected my app, because of some sound background playing whatever, no google search guide for that as well, I need to turn off something in xcode for that, just 1 line though, but the hassle of rejection and not granting my dispute

  4. #4
    Clicker Fusion 2.5 Developer

    Join Date
    Feb 2014
    Posts
    967
    Mentioned
    16 Post(s)
    Tagged
    1 Thread(s)
    can u tell me what the extra frameworks needed are? as i might run into this issue soon.

    & is there no way for clickteam to include all the needed admob frameworks in the exported game project file if u use the admob object in ur project? wud save loads of time

  5. #5
    Forum Moderator

    Fusion 2.5 MacFusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleUniversal Windows Platform Export ModuleSWF Export ModuleMac Export ModuleInstall Creator Pro
    Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)
    Perry's Avatar
    Join Date
    Dec 2013
    Location
    Watertown, WI
    Posts
    4,334
    Mentioned
    49 Post(s)
    Tagged
    0 Thread(s)
    GLKIT
    CFNETWORK
    MESSAGES
    MESSAGEUI
    COREVIDEO
    COREMEDIA

    All with .framework

    3 of those are not in the list yet. from the existing Admob items that you are already adding

    And no, don't think it's possible to add that in the project.
    I am working on something where you can add it with a program, but not sure yet if it works 100% still playing with it. (then you just run it, and it's all there)

  6. #6
    Clicker Fusion 2.5 Developer

    Join Date
    Feb 2014
    Posts
    967
    Mentioned
    16 Post(s)
    Tagged
    1 Thread(s)
    that sounds awesome

  7. #7
    Forum Moderator

    Fusion 2.5 MacFusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleUniversal Windows Platform Export ModuleSWF Export ModuleMac Export ModuleInstall Creator Pro
    Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)
    Perry's Avatar
    Join Date
    Dec 2013
    Location
    Watertown, WI
    Posts
    4,334
    Mentioned
    49 Post(s)
    Tagged
    0 Thread(s)
    I need 40 hours in a day.... I got so much stuff on my plate....

  8. #8
    Clickteam Clickteam
    Fernando's Avatar
    Join Date
    Dec 2006
    Posts
    6,130
    Mentioned
    152 Post(s)
    Tagged
    3 Thread(s)
    problem is that every new frameworks use different libs since the are making internal changes, latest 7.15 needs

    Regards,


    Fernando Vivolo

    ... new things are coming ...

  9. #9
    Clicker Fusion 2.5 DeveloperAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleSWF Export Module

    Join Date
    Jul 2006
    Location
    London, UK
    Posts
    86
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    It appears they keep changing which frameworks are required. You can follow the release notes at https://firebase.google.com/docs/admob/release-notes
    Latest appears to have added JavaScript core and removed EventKit, EventkitUI and CoreBluetooth.
    But then I still had 4 errors and worked out by trial and error that I needed AudioUnit.framework as well
    So now I just have one error of 'Linker command failed with exit code 1' which i've not resolved yet. The error descriptions says it's linked to the AudioUnit framework but I've tried a few things I've seen suggested in other forums with no luck.
    Think I might start again from scratch

  10. #10
    Clicker Fusion 2.5 DeveloperAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleSWF Export Module

    Join Date
    Jul 2006
    Location
    London, UK
    Posts
    86
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    So I kept the same project in XCode but loaded another mmf export file.
    I selected iAd as the only difference.
    I then re-added the latest list of frameworks but not including AudioUnit, and no errors this time.
    I guess if you add things that are needed it sometimes creates errors when you take them out.

Page 1 of 2 1 2 LastLast

Similar Threads

  1. Google Admob Native Ads
    By kiko in forum Android Export Module 2.5
    Replies: 1
    Last Post: 13th September 2019, 05:42 AM
  2. Error at compile apk
    By tiger19 in forum Android Export Module 2.5
    Replies: 3
    Last Post: 1st October 2015, 07:30 PM
  3. XCode ArrayList.h compile error.
    By Paul_Boland in forum iOS Export Module 2.5
    Replies: 8
    Last Post: 10th July 2014, 11:25 PM
  4. Compile error
    By Perry in forum Android Export Module 2.5
    Replies: 2
    Last Post: 10th July 2014, 02:06 PM
  5. XCode ArrayList.h compile error.
    By Paul_Boland in forum Fusion 2.5
    Replies: 0
    Last Post: 4th July 2014, 11:31 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •