User Tag List

Results 1 to 2 of 2

Thread: Strange bug with non apparent sense.

  1. #1
    No Products Registered

    Join Date
    Sep 2016
    Posts
    48
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Question Strange bug with non apparent sense.

    Hi people, please read this, of it depends my game and it's really important for me :'c. I have been working on a game for over 1 year and suddenly a strange wild bug appeared. (Sorry if my english is not the best, i might have many errors writing, excuse me for that).
    The thing is, i have 6 layers on one of my levels. I created the fifth and sixth layer to generate an darkness/lighting effect with torchs and stuff using substract effect on the fifth layer (on the sixth layer i put colored lights to make the effect of fire and diferent kind of lights).
    Everything was working perfectly, but suddenly a bug appeared. The animation of one object i used on the 5th layer was doing strange things, it kind of pops out or i don't know how is it called, it just dissapear and reappear. I thougt it was just a little animation bug of only 1 object, but enventually began to happen with almost every object at the 5th and 6th layer. It literally ruined the beatifull darkness effect i created :c
    And not only that, the bug apparently is corrupting the code or something like that because since that began to happen, more bugs are appearing: Some sounds don't work correctly, also the layer effect kind off mess up the effect of an object on layer 4 nullyifing it, and at one point the game just crash with the message "edrt.exe has stopped working".
    Something interesting is i found that only this last thing (the crash with that message) happens as well on 1 previous game and i didn't noticed before, and i managed to fix it now, it was being caused by 1 object, an object with no code at all, it was just a very very big active object with many animation frames. But then i tried deleting the big objects of my actual level (The one i explained at the start) but i doesn't fix the bug. Help please D:

  2. #2
    No Products Registered

    Join Date
    Sep 2016
    Posts
    48
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Yaaay! I just managed to found what was causing the bug and fixed it for myself n_n / Im posting this own reply just in case that someone reads this and has the same problem, so here it is what causes this kind of bug: An object to big And/or with toooo many animation frames. Idk if someone had an object with more than mine but, 300 frames of a 900x900 (pixels) object was enough to cause this strange horrible undesirable bug. I hope it can help someone with his own games :'D

Similar Threads

  1. how to make sense of Frames Per Second?
    By Volnaiskra in forum Fusion 2.5
    Replies: 4
    Last Post: 9th August 2016, 04:09 AM
  2. [Critical Bug - Beta 28] Crash on HTC Sense 4
    By scottige in forum Android Export Module Version 2.0
    Replies: 7
    Last Post: 27th June 2012, 07:57 PM
  3. [BUG] - APP crashes during a collision with background or no apparent reason
    By Ls2 in forum Android Export Module Version 2.0
    Replies: 2
    Last Post: 20th February 2012, 05:08 PM
  4. This dosen't make any sense......
    By Gimbabwe in forum Multimedia Fusion 2 - Technical Support
    Replies: 27
    Last Post: 25th July 2011, 11:42 PM
  5. Beginner question - does it make sense?
    By Leander in forum Hardware Accelerated Runtime
    Replies: 3
    Last Post: 8th June 2010, 02:08 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •