[Solved] Save Array doesnt work (DataStorageDirectory$) on Android

Welcome to our brand new Clickteam Community Hub! We hope you will enjoy using the new features, which we will be further expanding in the coming months.

A few features including Passport are unavailable initially whilst we monitor stability of the new platform, we hope to bring these online very soon. Small issues will crop up following the import from our old system, including some message formatting, translation accuracy and other things.

Thank you for your patience whilst we've worked on this and we look forward to more exciting community developments soon!

  • I'm having another problem with saving and loading on an Android smartphone. I had this problem a few years ago and now it's back again. When I test the app with "Run Application" on Windows, saving and loading an array file works. But nothing is saved on the Android smartphone. I have already tested whether the array is entered correctly and apparently that is not the problem. I always build my app with API 33.

    Thanks for your help.

    I have also attached a test file that works under Windows, but not on the phone.

  • Android is limited with handling the filesystem on phones etc... Have you tried doing manually with INI files. that seems to work with the filesystem. And if u dont want ppl to edit the stuff. handling it with custom values. like a value of 7 * 7435687 - 3434 * 34, and when loading it back in reverse it.

    I think only known safe files are allowed to be written on the phone from your app/game.

    You can use a fastloop to save an array to ini
    save value to ini arrayx-arrayy=string or value
    If your using values and strings.

    If using ini on android check "save ini in application data folder"

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!